ring is in boot loop even after reset

Hi. I bought and succesfully installed a ring 2 doorbell which we used without problem for about a month. Then we removed the battery to charge it. Put the battery back in and the ring doesnt work when you press the button, nor are there any notifications (the settings are on). The video and sound both live and recorded work. I tried to reset it and now the blue lights are continuously flashing to indicate booting but they wont stop.

What do i need to do to get this going again?

Hi @rigger100472. In this case, the most basic things we can do are removing and reinserting the battery and trying a reset. It sounds like you have already done that, so I would suggest reaching out to our support team. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.


I have exactly the same problem. Not yet called support but woukd be interested to know if this problem was solved