Ring indoor cameras becoming bricked


The other day an indoor camera that had been running fine for weeks mysteriously died. I had to call in a replacement. Before the replacement arrived I had a new in box unit to setup and used that instead. Now mysteriously that camera has died too.

The symptoms appear to be that the camera will work fine, then lose network connectivity. Via device health you can get it to rejoin the network for awhile and it will drop off again the same day. After a few attempts at this the device will completely die and go non responsive.

Did I just unfortunately get a bad batch of indoor cameras or is a new firmware version to blame? I’m holding off calling support to see if the final new in box unit I had suffers the same fate.


1 Like

Hi @SeekingHelp! If your Cams are completely unresponsive, the best next step will be to attempt a reset by holding the setup button for 20 seconds. I recommend also trying another outlet in your home to ensure the Cam is powered properly. Once confirmed, if this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

This has now happened to 3/4 of the indoor cameras I purchased. Using different outlets.

1 Like

Sorry to hear about this, as it should definitely not be happening, and is not the experience we intend. Our support team will be happy to help you obtain a solution. Feel free to let us know how it goes!

That’s really odd of 3 out of 4 have had the same issue. What did support say?

1 Like

I am having the EXACT same issue and symptoms with the camera. I have others that (so far) have not done this. I am SO frustrated trying to get Ring Support and help. Horrible company for actual employees to connect with. Did you ever get a fix or are yous till struggling?

They replaced one of them. I’ll have to set it up again. I was emailed a follow up to see how things were going and provided all the details of 2 more cameras that would need to be replaced. Unfortunately it has been almost a week with no response so I’ll have to call back again. The loss of wifi to me says it’s a bad batch of equipment or a firmware problem. So far only one camera has been able to hold a connection reliably. Interestingly enough it is the only one that I didn’t wall mount. I’ll report back if the replacement camera stays reliably connected when wall mounted.


Nice to know you are not alone! Same problem here, had the cam 3 days. Died last night. Replacement on his way. Hopefully working better!

1 Like

Same thing happened to my one

I just installed an indoor cam today. It worked for about 10 minutes, started the update process, said it would take a bit of time and the light would blink as the update was underway. It blinked about 2 times and that was it.

It’s dead. Cannot repair it, Cannot get it to turn back on. Holding the button for 20 seconds is not factory resetting it.

Something is wonky in that code or the hardware.

Support was very nice and they are getting it replaced for me.


It happened to me yesterday after the basic install completed and the Ring Indoor Cam said it was updating its internal software. No blue light after holding the setup button for 20 seconds and changing to a different outlet. Ring support said to replace it. Ordered new one from Amazon, but afraid to do the setup as the internal software update is done automatically. :frowning:

Just bought an indoor camera from Home Depot tonight and the same thing happened. After firmware update, the app said the camera was disconnected. I tried to reconnect, but the camera is “bricked.” I tried a different outlet, held down the reset button. Completely unresponsive. No indication at all that the camera is powering up.

I’m returning tomorrow to HD to get a new one, but am concerned the same thing will happen. Very frustrating!

The same exact thing happened to both my cameras. They went through the setup, worked for a few minutes, then said updating and subsequently bricked themselves. Pressing the button on top for 30 seconds does nothing. No lights or anything that shows that the camera has any life.

Anyone find a fix?

Did your new one work? Or is it a problem with the Ring firmware update?

The only solution for me was to exchange my cameras for replacements. Never had a problem since. Best to contact support and setup an exchange.

Same thing here after the initial update out of the box

I have had the same issue. 4 of them worked and another 4 of them have issues

Hey neighbors! If you’re experiencing your Indoor Cam becoming unresponsive, call our support team for further assistance. I’ve notified our teams that quite a few of you are experiencing similar issues, and they are actively looking into this. Once you’ve made contact with our support team, they will be able to gather more information and get your Ring Devices back on track. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I just picked up another Indoor Cam today and feared I’d have this issue, but fortunately everything worked fine. Make sure you’re allowing a lot of time for the camera to update and reboot before pressing any buttons, or power cycling the camera.

I wanted to share what I noticed as I set this up. Maybe it will help some of you, maybe it won’t…

Today’s new Indoor Cam is my 3rd one, and 7th overall wired Ring camera. I’m fairly accustomed to setting these up. I noticed this time, this Indoor Cam took quite a while to setup and install the updates. Curiously, the app reported the firmware was already up to date. However, the blue circle/refresh symbol appeared over the thumbnail of the tile, and I couldn’t access Motion Settings because the app would tell me to wait as it finished this update.

I noticed the blue light on the camera turn on/off several times. It would blink a few times as well. Then, after easily over 5 minutes, the camera powered off and went offline. I had a message in the app the cam was offline, and the blue light wasn’t doing anything. It remained off for a good 2-3 minutes and I thought for sure the update bricked it. Then, the blue light lit up and the camera came back online. The entire update process probably took around 10 minutes. My WiFi is fairly fast, but this update/setup easily took longer than any other Ring cam I setup–including the other 2 Indoor Cams. That cam is setup and working perfectly fine now for a few hours.

If you’re not, make sure you wait long enough for the camera to reboot after it shuts off. I’m wondering if maybe someone hits the setup button, or power cycles the cam during this point is causing them to brick. Again, that’s at best just speculation. Once it starts updating, just let it go and walk away for 10 or 15 minutes. I thought for sure mine was dead but it ended up being fine.

Hopefully this might help someone. I know I’m NOT the most patient person at times.

1 Like

This also happened to me twice- once with the original camera and again with the replacement. Both times I left the camera alone for at least 1/2 hour while it was updating. Hoping that the third camera works