Ring Indoor Cam never recovers from initial Firmware Update

I recently bought 4 of the Ring Indoor Cameras for our home (we have an Elderly Mother-in-law to keep an eye on). 2 of them setup without issue, however 2 of them I was able to pair and go through initial setup (Connected them to wifi, my Eero saw them, all was good). They then went immediately to the initial software update, and never came back.

Now, it seems like no matter what I do they’re dead. No lights. Power cycles, different outlets, different cables, holding the button for 20s, 30s, a minute… Is there any way to recover these? Did I do something wrong in the setup?

1 Like

I have the exact same issue. It worked well during set up and after firmware update went dead. Any solution yet?

None yet.

Three other cameras updated and are working well. One would just not show any sign of life.

I’m having the same issue also

Same issue

I have now been through not 1 or 2 or even 3 but 4 of these now and they have all worked for only minutes before the camera says, “now performing software update, this may take a while so please be patient” then the camera falls off line and NEVER COMES BACK. I have let the cameras sit for over an hour after doing the update with no prevail. I tried to call Ring and had a grater than 45 minute wait to talk to a represenetive. Their services have been down all day today now 4 of their cameras bricked after their software update makes me want to cancel all my services with Ring and find another company.

Same exact thing happened to 2 of mine. Just bought them, set them up, worked during set up, but then crapped out after the update.

I have same issue. I have experienced this in the past whereby the update finally finishes but not this time, this one is still non responsive.

Same situation here. Installed 3 weeks ago, went to black and white Wednesday morning, stayed there in spite folliwing the instructions

Hey neighbors! If you’re still having this concern, I recommend following up with our support team on this. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I did. Rep told me an issue with the firmware. Monitoring. No ETA on fix.

It would be helpful if you posted the status of this.


Yes I had this same issue and here is the problem. The resident firmware is an outdated version so once the initial update gets downloaded the camera will brick for good.

I just bought 4 Indoor Cameras from Best Buy. THREE went dead within 4 minutes of setup!!! Two Ring techs and a couple hours on the phone later, the Level 2 tech decided to look up the resident firmware version and found out it was outdated.

Get a Ring tech on the phone and have them look up your MAC address to the device. That should get them going for a refund/replacement. Word of advice…Buy the extended warranty and all your devices are covered for their lifetime.

I tried again. Worked flawlessly!

I did remember to disable cellular data and refresh app before proceeding with the install.

Previous failure may have had to do with the recent outage.

Nice Cam for the money. Hope it lasts awhile!

1 Like