Ring indoor cam 2nd gen, showing offline but still working

So my ring indoor cam 2nd gen is showing that its offline, but its blue recording light is coming on with motion but it does not save any video. I reconnect it to my WiFi and within 30 seconds its appearing offline again, its only 3 feet from the router and all my other cams are working fine, all much further away from the router, and there is nothing obstructing the connection in the way from the router to the cam. It connects to the correct 2.4 network, and I have tried changing the networks channel through the router and nothing seems to fix this issue. The cam is barley 2 months old. Has anyone had this issue and have a fix I haven’t tried yet?

Hi @Bigollunchbox. What is the RSSI for this device? Does your device behave this way if you connect it to a WiFi hotspot?

The RSSI is 38, and it does it connected to any WiFi.

Hi @Bigollunchbox. Who is your ISP and what model router do you have? Do you have a Chime Pro?

I have Comcast, and its the gig plus router offered from Comcast, and yes I have a Chime Pro. It does the same with the chime pro.

Hi @Bigollunchbox. Thanks for that information. It looks like this issue will need to be looked into a little closer. Please send us a private message on Facebook @Ring or give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support. Feel free to follow up with us after our support team takes a closer look.