Ring History will not play on phone or web

For weeks Ring recordings in History will not play on the phone app or via web account.

I have tried deleting and reinstalling the phone app as recommended on other posts, but it does not help.

Hey @GK7983. Could you share a screen recording or screenshot of what happens when you try to load an event from your history? Please note you must have an active Ring Protect Plan in order to see your history in the Ring app.

Hi Chelsea

My account is up to date. Payments are reflected on my CC as they should.

Attached is a website shot of the history section. It shows events but also shows an error. Clicking on an event does nothing.

On the phone Ring App, same experince with the history section. Clicking an event does nothing. Under the cameras section, clicking on front door bell cam brings up the scrollable timeline view, works fine. Grab attached. So the camera is operating.

Activing the door ball camera in Live mode fails more than it works.

Thank you

@GK7983 Thank you so much for those screenshots! On the mobile app, you’re getting the same error message as the message you got on the website, correct? Since it looks like your phone is connected to wifi and I’m assuming your computer would be using the same wifi, do you have any VPNs enabled on your network? Ring does have restrictions when it comes to VPN usage, so I wanted to rule this out in case! If you do have a VPN, please disable it and let me know if you come up with the same conclusion.

In the event this is still not working, could you let me know what kind of phone and browser you’re running this on? Please include your phone/computer type, OS system, and app version (for browser, just let me know the type of browser and the browser version, if possible). This information will be very helpful to pass onto my teams to take a deeper look into this! Lastly, let me know what your Device Health page on the device’s profile looks like - battery level, online or offline (I assume online but want to make sure), and the RSSI!

Once I have this information I’ll be able to help guide you with the next steps. Hope to hear back from you soon! :slight_smile:

On the mobile app view of 'History" I do not get an error, but clicking on an event does nothing.

Re VPN, I have no router level VPN in use, never have. I do have 2 laptops with VPNs installed that are on the network ocassionally. I’ve confirmed that both were shut down, then rebooted the router for good measure. No change to Ring functionality.

Re phone details, my wife and I are both experiencing the same issues. Both are iPhone 11 models. I believe app ver is 5.25.0, redownloaded this week from Apple’s app store.

Re computer details, iMac running Catalina 10.15.4. Brower, Safari 13.1. Same issues when using FireFox 75.0

The phone app device health and system status views show all is normal. Screen shots included.


@GK7983 Thank you for the followup! You really are diligent in your troubleshooting work, so I applaud and thank you for this. At this time, I think you may need to reach out to our support team via phone for some advanced support. What they can do is check how your recordings are showing on their end, if they can do any playback, and isolate why this is happening.

If you could, please give them a ring at any of the numbers here, and please let me know what they were able to pinpoint and figure out for you! Feel free to have them reference this Community thread to showcase your examples and troubleshooting already done, as this will help speed up the resolution process for them! Thank you neighbor, hope to hear back from you soon. :slight_smile:

Exact same issue updated subscription, internet is fine. Recordings will not play from anywhere (app or web) and when I click on them nothing happens. Deleted the app reinstalled and same issue. Help please!!

Just more info alerts/notifications work and live view work it’s just recordings not working.

I had this same issue. Called support. After trying a few things they suggested removing the doorbell from the mount to do a hardware reset. Push the button on the back. It walks through a fresh setup on the app. That fixed the issue for me.


Did that now I can’t play recordings and I have no live video either, wondering if I have hardware failure