Ring Hardwired Floodlight Cam not connecting and making clicking noises

So a couple weeks ago, seemingly randomly, my hardwired floodlight cam stopped working. It disconnected when Internet to my house went down, and it never came back up.

Ever since then, it just sits there and clicks. The bottom light flashes green when it clicks, and it does it in consistent intervals. I can’t put it into setup mode, and I can’t even hard reset it by holding down the top button for 30 seconds.

I have checked the wiring, and everything is correct, and is exactly where I left it. It worked for a few months before this started happening…

I am at a loss… Please help!

Sorry to hear about this, @synapse! It sounds like it might be attempting to function or reconnect to your network, but is odd to hear that the setup button or reset did not resolve this concern. Although you may have covered this step, try powering the Floodlight Camera for a few moments, then power it back on. Please also ensure your router is as close as possible to the Floodlight Camera location.

If the Floodlight Camera does not automatically reconnect, please reconnect your Ring device by following the steps in this help center article.

If you are still having this concern after completing those steps, our support team is happy to help further! :slight_smile: Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.