Ring Floodlight issue,Lights don’t come on

I have just installed my ring floodlight cam, set up went smoothly, camera and siren work fine, but I cannot get the lights to come on. When I toggle the switch on the app, the app says they are on, but no lights at all!

Any advice welcome?

Hi @Jimbobn. Try disconnecting power from the Floodlight Cam for about one minute and then reconnect it. If the lights are still not coming on after that, you can reset the Floodlight Cam by holding down the setup button for at least 20 seconds. After the reset is done, you’ll want to set the Camera up in the Ring App again with the steps under Set Up a Device.

Should the lights still not come on after these troubleshooting steps, I’d recommend reaching out to our support team so they can take a closer look and offer more advanced troubleshooting support. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: