Ring Floodlight has started to Strobe/Flicker

Ring Floodlight has recently started to strobe/flicker. There have been no changes to the wiring, location or anything over the couple years that we have had it installed. There have not been any issues relative to temperature that would cause any issues either as this is the first time in the couple years of installation that we are having problems. Lights are no longer usable as the strobe is an annoyance to not only our neighbors but us as well. Are there any replacements parts that can be provided? Please help

3 Likes

I can tell you this is going to take a call to Ring. See if they can figure it out and if not, just ask for a replacement to be sent out.

Hi @braneo. You may want to try a quick reset and fresh setup on the Floodlight Cam to see if this resolves the flickering you’re experiencing. You can reset the Cam by holding down the setup button for at least 20 seconds. Once that’s done, you’ll just want to set it back up in the Ring App with the steps under Set Up a Device and then test it out. If the flickering persists, as @trail-explorer recommended, you’ll want to reach out to our support team so they can troubleshoot this deeper.

You can give our support team a call at one of the numbers available here. If you are outside of the US, please go here to see how to contact support. Definitely feel free to report back in this thread on what solution works for you. :slight_smile:

Hi I am seeing the same issue with my floodlight cam. Originally the power fuse was tripped and so I flipped it back on from the circuit breaker box to restore power. However its been strobing since this morning til now (for 8 hours and counting). What exactly is the problem with the new floodlights? I also have the original ring floodlight cams that I have around the house, and tried to restore power to them, and they connect back to the network just fine. (I manually flipped the circuit breaker to test it out) However these new floodlights (floodlight cam pro), which I got two, both have not connected back to the wifi network and keep strobing.

Help!

1 Like

live view from my ring door bell of my floodlight cam pro strobing. hasn’t fixed itself yet.

5 Likes

OK - this has now started with one of my floodlights - out of the blue! I’m going to try the suggestion of resetting it, but will have to wait until morning since I have to set up a tall ladder to reach it. SUGGESTION: Instead of having to climb up to reset floodlights by pressing an inconvenient button, how about programming them to reset by 3 quick on/off cycles or something? I’m sure I’m not the only one who has installed their floodlights up high on their house!!!

3 Likes

Having the same issue. First a couple months ago happened a day after install. Replacement one happened two months later. You can see there has been many submissions about this issue and they just close them as resolved by giving a generic answer. Do they think we’re all idiots and don’t know how to try all those steps before we reach out? This isn’t a new issue and has happened with ring spotlight camera for years, just wish I would have known that prior to purchase. They’ll just send me a new one again, will keep doing that since I can’t return it.

BTW be prepared to wait 30-45 minutes to even speak to someone, supposedly due to COVID. You can catch COVID variant through the phone now :joy:.

3 Likes

I had the exact same problem with my floodlight cam. It is faulty hardware. You will have to call “support” and wait/work with them for 2-3 hours so they can walk you through all the steps already performed through their tips on the website. Once that’s through they will send you a new one.

I have experienced the Same annoying issue twice. Very annoying. The first time I was able to reset by climbing on a ladder on long call with support but second time the reset didn’t work. Both times loss of power by flipping a circuit breaker. They sending me a new floodlight pro camera but now I have to pay someone to reconnect. Unable to turn off without shutting off power to garage door. garage door. Not happy. 😵‍💫

Same exact issue. What a pain in the rear.

I have the same issue. It has been going on for months. Resetting doesn’t fix it. As a licensed electrician and automated building controls specialist, I know I am going to be very annoyed by tech support.

This is a hardware issue, no amount of turning the power on and off or resetting is going to fix the problem.

I am having the exact same issue now. What’s the fix? Do you have to replace the entire fixture?

Hi @Tom106. If the troubleshooting steps previously recommended in this thread don’t resolve the strobing or flickering you’re experiencing with your Floodlight Cam, I recommend reaching out to our support team so they can look into this further. They will ensure all troubleshooting steps have been tried and then check the warranty on the device to see if a replacement is necessary. You can give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Have seen lots of posts about strobing lights on the Flood Cams. This is a hair over 2 years old and they’re telling me I need to purchase a while new flood cam but they’ll give me a discount?? What is this? Because your product is cheap and you can’t resolve it after all the tips/tricks/resetting, etc. I have to pay more money for an inferior replacement? With as many people who have reported this, this has got to be a known defect.

I’ve got an issue with three cameras on the same house . Had a power cut now they are all strobing and will not connect . Ring support were terrible and spent 2 hours on the phone .

They have sent me out a battery stick up camera as a direct replacement because they have no stock . I have been without one of the cameras for 3 months so my customer is fuming .

The cameras are less than 12 months old and they won’t send a refund . I’ve contacted them again and asked for a representative to call me but I’ve heard nothing . Ring aren’t a good company and the support is terrible . I’m currently over £650 in deficit with three non working cameras .