Ring Floodlight Cam no longer connects to existing Wifi

I have an existing Ring system that has been installed for about a year. Our power went out for two days due to hurricane Ian, and when it came back online, the system and all devices reconnected except one hardwired floodlight cam outside. The camera worked fine until the power went out, last connectivity showed signal strength strong (RSSI-73), firmware up to date. I have a mesh router and it runs at over 300MB.

I powered the camera off and on, held the reset button on top for 20 seconds, and the bottom light flashes and it says now in Setup mode, on my existing WiFi (which has not changed nor the password), but it then fails when I try to join “Ring Setup ba.” I get the now audio now in Set-up mode, and it runs through the process including joining my WiFi network. I then fails at the unable to connect to “Ring Setup ba” in my wifi when I go to settings. It seems like it is the last step.

I powered off and back on my iPhone also. I did change the Settings app on my iPhone to say “Ask” under Ask to Join Networks per the troubleshooting guide.

Not sure what else to do. I have powered if off from the switch several times and left off for 5 minutes plus, and same thing.

Hi @TB14. The RSSI seems to be the problem here. As you can see in this Community post here, an RSSI of -73 is extremely poor. I suggest adding a WiFi extender such as a Chime Pro to improve your connectivity. Until you can improve the WiFi signal at the location of the Floodlight Cam, you will continue to have connection issues.


I re-checked and the RSSI was 54, not 73. Also, as I mentioned, it worked previously without issue. Is there a way to connect using the QR code instead?

Thanks so much

Another “Tom”


You can disregard, after about two hours, I got it to connect. May be a faulty camera for setup.


1 Like

Hi @TB14. Glad to hear that you got this working!