Ring floodlight cam LEDs stuck on

8 month old floodlight security cam. In the past few weeks, it has started getting “stuck LEDs” that are on all the time, even during the day. So, when the lights are supposed to be OFF (nothing is moving) these LEDs are still on, during the day or at night. Once movement triggers, then everything comes on bright like it is supposed to. I took the unit back apart to see if the wiring was messed up or if there were bugs in there somehow messing it up, but all is good. I even added some electrical tape to the wirenuts. Still does it. I tried unplugging it and plugging it back in and that doesn’t fix it either. Kind of annoying to neighbors that this thing shines light all night long when it should stay dark. How do I get a replacement unit? I’ll also post a pic of the issue here so you can see what I mean.

Hi @user21529. You will want to verify that there is not a Light Schedule in place keeping the lights on all day and night. If you do have one in place, remove it and see if the lights behave normally. You can also try to reboot the Camera using the Ring app. If you have tried these other steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

1 Like

Managed to fix this exact same scenario on two of my floodlights with support by re-running the setup routine for the light. Rebooting the device was not working in my case.

To fix, hold the button down on the top of the camera for ~20 seconds and device will go back into setup mode. Go into your phone app, devices, click on the problematic device (which will now be offline), click on device health, and then click on reconnect to wifi. The phone app will run thru the same routine that you did when you first set up the camera (eg it’ll ask what wifi to hook up to, etc). When the process completes, the camera should be back online, but the LEDs will now be off.

Hopefully this works for anyone else out there with the same problem.

(FYI, both my lights seemed to start having the problem at around the same day which tells me an Oct 2022 firmware update may have been the culprit? Nonetheless, re-running setup worked for me.)

1 Like

Hey @SaturnMan, thank you for sharing that troubleshooting step which worked for you. We will typically try to recommend rebooting the device via the Ring app as a simpler troubleshooting step to start off with. If that doesn’t work, completing a reset and a new setup like you outlined is definitely what I would recommend next. Glad to hear your Floodlight Cam is working as expected now! :slight_smile: