Ring Floodlight 2 will not reconnect to home wifi

Hello. I recently changed my Google wifi password due to security issues. Since the password changed, I had to reconnect my Ring devices.

I have Ring Floodlights (with Ring Bridge), a Ring Floodlight Cam 2, and the security system. The floodlights and security system were able to reconnect to the wifi without any issues.

However, when I tried to reconnect the Ring Floodlight Cam 2, it did not work. I tried to reset the router, the Google wifi, power down the electrical circuit serving flights, and even did the factory reset. None of these methods allowed me to reconnect to my home Google wifi.

It had no issue connecting before, so I’m not sure why it’s not working this time around. I tried the hotspot method I read from another thread. It was able to connect from my phone’s hotspot without an issue. But when I tried to change networks back to my home wifi, it would not connect again.

Any help from Ring would be appreciated.


Hi @user69160. Which model of Ring Floodlight Cam do you have? The device name is listed on the Device Health page in the Ring app. Most Ring devices are only compatible with 2.4GHz networks, but some are also compatible with 5GHz networks. Knowing specifically which model of Floodlight Cam you have will be helpful to determine this.

Also, are you receiving a specific error message when trying to reconnect in the Ring app? If so, feel free to share a screenshot demonstrating when you’re seeing on your end. We have various troubleshooting steps here regarding the setup/connection process that may help.