Ring Floodcam Pro freezing recordings and missing motion

My FloodCam Pro recordings freeze very frequently and the rest of the motion/recording is lost even when I know there is continued motion (I’ve even tried going out myself and walking around - sure enough only part of my motion is recorded, the rest frozen/gone). I’ve tried every different Video Recording Length setting, that doesn’t fix it. I replaced my router, but that didn’t fix it. I had my internet provider out today check all my connections and signal - they say it’s all good, but I still have this ring recording issue. I don’t recall ever having this problem with my older (not PRO) floodcam but after upgrading to PRO I’ve have it constantly (since it was installed). I also have a problem of it writing over recordings so data/motion is lost forever. I’ve called Ring Support - they’re really useless & it’s frustrating. They just blame problems on others. I’m not a techno wiz and would appreciate some plain language help/advice pls.

Hi @pams16. What is the RSSI for your Floodlight Cam Pro? This is located in the Device Health menu. What type of router are you using? Are you connected to a 2.4 or 5 GHz network? As a test, try connecting your Floodlight Cam Pro to a WiFi hotspot and see if the freezing stops. This will help narrow things down for you.