Ring Flood light cam light not working!

Just installed new Floodlight cam and I was trying to set light schedule to stay on between 530pm til 1000pm. The lights do not turn on when schedule says and does not turn off at end time. Am I missing something? Doing something wrong? Any help greatly appreciated!!!


I have the same issues, so looking for help on this too.

Please let me know if you get it resolved!! I will do the same. Thank you

I am experiencing the same issue. Searching the internet, I see people complaining about this as far back as 6 months ago.

In my case I have the lights scheduled to turn off at 6am but they turn off somewhere around 1am.

I actually wonder if the software doesn’t adjust for the timezone correctly. Ring?

I just spent a some time with ring support troubleshooting this. What I noticed is that the scheduled worked correctly when entered as UTC time rather than my local time. When I relayed this to the support agent, she adjusted (on her side) timezone for the camera and my schedule started working again. Note that in my app the timezone was already set correctly, it had to be adjusted from the Ring end.

Try it with your camera - set the schedule as though the times were in UTC (ie if you are on east coast and would like your camera to switch lights on at 8pm, don’t set 8pm, set 1am). If that works for you - contact Ring to adjust the timezone for your device.

1 Like

Thanks for this, I tried this…but my lights just never come on. I was hoping it was a timezone thing.

I too am having trouble with the time on/time off, on one of my floodlight cams. When I set the schedule for the floodlight to come on, it works for a day or two then it stops working. Both of my other floodlight cams are working fine, according to the schedule I set them up for. It’s only this one that doesn’t want to comply with the schedule I set up.

I’ve heard from some people that Ring uses GMT, which is five hours ahead of EST. As I type this the clock in the blue bar above says it’s "Autosaved at 7:58 PM. It’s 10:58 PM here. So why is the clock showing a three hour difference instead of five hours.

And by the way, I would like to solve the floodlight issue.

Same issue light will not operate as it is scheduled. Seems to come on when i save the schedule but a while later i look and it is off . Anybody got a fix?