Ring Elite No Longer Connecting to Network

I’m with a home automation/ integration company.

I installed a Ring Elite a while back for my customer. It’s been working just fine and powered via POE. It recently has lost connection with the network.

I’ve verifed that the POE is working fine and in fact tried a backup unit. The network connection is also working just fine. I even verified all the cabling and POE power supplies.

The unit will power up based on the fact the indicator light is lit up around the doorbell button (light blue). However, if you look at the indicator light at the network switch the POE is getting it’s feed from, the port shows no activity. As if nothing is plugged into the network port. I’ve taken the unit off site for a closer look. It’s exhibiting the same behaviour on completely different network switch and POE injector.

I’ve tried several times to reset and redoing the setup. With the iphone app, I get as far as "Ring wants to join wi-fi network “Ring Setup 4e”?, however my phone fails to join network after many repeated attempts. It’s as if the Ring doorbell isn’t broadcasting an SSID during this stage of setup. While in this state, I can see no activity on the network switch providing a LAN connection to POE. If I perform a network IP scan, the Ring doesn’t show up.

Is this unit faulty?

Hi @knox. Thank you for taking the time to provide a detailed explanation of what you’ve tried so far and what results you’ve received. The Doorbell should be maintaining an internet connection based on what you’re describing. Since you have done the basic troubleshooting steps already, you’ll want to reach out to our support team for more advanced and in-depth troubleshooting. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to report back on what solutions our support team recommends. :slight_smile:

@knox – what was your resolution here, if you don’t mind me asking. I’m having the same problem/symptoms.

The unit was working fine for 3 days, then went offline. With help from support, I was eventually able to convince it to go back into “setup” mode (though it took about an hour of fiddling while on the phone), and it connected again. Fast-forward 30 days, and it went offline again, with the same symptoms.

Plenty of power from the PoE. Switch shows the "power "light, but not the “data” light. I’ve tried different cabling. I’ve also got 3 Stick-up Cam Elites on the same switch, and no network problems with them.

I’m trying to go through the setup process again, but am having trouble (again) getting it into setup mode. (It takes about 10 minutes to reboot and get to a steady state, and pressing the button to enter setup mode doesn’t work, leaving no course but to reboot again.)

FWIW, I’ve managed to get it into setup mode a couple of times, now (it’s a crapshoot whether the device will respond at all after a reboot), but it doesn’t appear to be broadcasting an SSID, similar to your previous experience.

FYI: Contacted support, and we exhausted the troubleshooting options, so they’re sending me a replacement.

1 Like