Ring Elite mechanical bell stopped working

Hi there — So our mechanical bell (inside) recently stopped working and I’m trying to troubleshoot. Two things I’ve tested:
—The app is correct in that the mechanical bell is enabled and I even removed/added the Ring Elite.
—I disconnected the bell wires from the back of the Ring Elite and touched them together. This does ring the bell.

What would you try next? Would the bell work via the wire touching method if the transformer was acting up? That’s all I can think it could be unless it’s the connector on the Ring Elite that’s somehow not bridging the connection…

TIA!

2 Likes

Hi there, @Adrift02! You’ve definitely covered the best steps for troubleshooting this concern. With the chime kit ringing successfully from touching the wires together, this does indicate at least enough power is being supplied for that chime kit. In most cases, the power needed for a mechanical chime is also sufficient for our Doorbells to utilize. While this may have worked before, it may be worth checking the Chime Compatibility list for this chime kit. In regards to the connection on the Elite itself, please ensure there is not any debris or corrosion of wiring where it is connecting. Please also ensure the wiring is not too thin, as this could cause resistance in power.

Otherwise, the best next step here will be to reach out to our support team for a more in-depth look. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know how this goes! :slight_smile:

I have a Ring doorbell Elite connected to a mechanical chime and has been working fine until last week. The chime stopped making the sound, I do receive the notifications in my app.
My chime is BK242LWH which is in your compatible chime list.

If i test the chime with the voltage needed is working perfectly, it seems the ring doorbell is not sending the voltage to the chime. Any inputs here? Thanks

3 Likes

Ring doorbell Elite with Power over Ethernet has been working for over two years. Recently it stopped ringing the mechanical chime. When the black button is pressed the sound goes off at the doorbell and the blue light comes on but the mechanical doorbell does not sound off.
I opened it to check all wiring is good, I shorted the two house door bell wires and the mechanical chime sounds off fine, just not when i press the doorbell black button.

Any pointers appreciated.

2 Likes

Seems like this might be a somewhat widespread issue with the device? Many of my neighbors (tract homes with builder installs) reported the same thing — just 1-2 year old installs.

Regardless I’ll try calling… and report back if any of you learn anything thanks!

1 Like

Same thing here - ring elite doorbell stopped triggering the mechanical bell about 2 weeks before Christmas.

Setup - Ring Doorbell Elite connected by ethernet cable and using PoE for power. Byron 776 wired chime with internal AC transformer. No Ring Protect Plan subscription.

Was working fine up to two week before Christmas. No

  • Wired door chime works fine when the wires are shorted together.
  • Reset Ring Doorbell Elite and update software (press ring doorbell reset button for 15secs, re-add via app, setup as ethernet, setup as mechanical door chime, wait for software update).
  • checked wired chime is on the compatibility list - byron 776
  • checked that is wired to Rings recommendation - yes, byron 776 has an internal 8V ac transformer
  • checked voltage on wired chime - 15V ac
  • checked wired chime cable - yes, Ring doorbell is now setup on the bench and has a new cable connecting it to the wired chime.
  • checked that the terminals on the Ring Elite are to corroded - yes, looks as good as new

I have also used a multimeter to see if the terminals on the Elite ‘switches’ the wired chime voltage - it does not - it did a few months ago.

Have spoken to Ring Support who have run through most of the above. They have taking the view that there is nothing wrong with the Ring unit.

Please update when this thread has a solution, probably a software fix.

I am having the same issue as the previous posters above, started around Nov of 2020. No mechanical door bell activity when Ring door bell is pressed. I have also tested that the mechanical door bell and wiring are working when the mechanical wires are touched together.

Ring Elite Door Bell was installed when the home was built ~2years ago.
All other Ring functions are working.

Same exact issue as everyone else starting in same time period. Builder installed 2 years ago.

Completed an hour long session with support and at the end she told me it was likely an issue with my ring device. Told me I’m out of warranty and issued me an out of warranty credit to go towards a replacement.

Not convinced that it is a hardware issue after seeing this thread. Definitely not shelling out for a new elite.

I have same issue with poe ring elite. Tested my door bell just fine using old button. Tried powering off elite and issue still exists

Same issue here. Unless all of these Ring Elites are all scheduled to fail at the 2 year mark, I’m willing to bet this is a software problem that started occurring sometime last month.

Same issue here in our neighborhood, Elite stopped activating the chimes.

From reading other threads who have the same issue, it seams the firmware pushed on Dec 12, 20 is when this issue started, phantom rings when infrared is active & no chime when the button is pressed.

I have the same issue. And the issue started around the same time. I called tech support and they’re saying that it’s the chime that has the issue, the Ring Elite. I also suspect that it has something to do with their firmware. Is there a way to find the firmware version?

It seems everyone started getting this issue from Dec 2020 and I am on the same boat as usual. It seems its a brand issue to make a force upgrade.

Ring must answer to this common problem

I also have the same problem. My in-home mechanical chime is not ringing when connected to Ring Doorbell Elite. It is working fine when I short them. It was working for the past 2 and half years and all of a sudden it stopped working, probably on the same timeframe others also faced the issue. Restarting Elite didn’t worked. Looks like it is a firmware problem.

Same issue here. After replacing Ring Elite under warranty. The same issue continued. Ring rep acknowledged firmware update made changes to mechanical bell. My home is smart home with Alexa throughout the home. The new firmware will disable mechanical bell if ring device is added to Alexa. Alexa overrides the ring setting and uses Alexa chime. I had to disable ring in Alexa to allow mechanical chime to work. Therefore if you have Alexa in your home try to disable ring from Alexa and see if this works for you.

I am having the same issue since end of last year. In my community other users are facing the same issue. I don’t have Alexa notifications enabled. I even reset my ring device to factory settings, but that didn’t resolve the issue. Is this a marketing ploy by ring to buy their chimes? I don’t understand how so many users are affected and when you call them they claim they haven’t heard about this issue.

I’ve been experiencing the same issue since early December. I called Ring and went through the troubleshoot steps. They suggested the Ring is the problem and suggested I replace the device! I have notifications through Alexa as well.

Hi neighbors, our team is currently investigating this, and we appreciate all of your feedback. It’s important to still cover the recommended steps for getting your chime kit to work. These are:

  • Checking our Chime Kit Compatibility List.

  • Confirming the chime kit works without the Doorbell Elite.

  • Ensuring wiring is securely connected to the holes on the Doorbell Elite, and that wiring is not spliced, frayed, or corroded.

Furthermore, if you have an Alexa skill enabled please try disabling the skill. If that resolves the concern, give our support team a call so they can collect more information. Thank you! :slightly_smiling_face:

Aaarg, same here folks! Ring Team, please confirm the is still being looked into…