Ring Doorbell3 fails to complete setup

New Ring3 DB and Chime 2nd Gen bought for Christmas. Can’t get the DB to connect to the wifi. UK Based with Cisco 887 router for Internet (and providing DHCP Server functionality) and Cisco 1142 AP providing the wifi. All other devices in the house using wifi without issues on both 2.4 and 5Ghz bands.

Have tried the following:

  • Turned off 5Ghz only using 2.4Ghz
  • Reset DB via orange button
  • Changed various settings on the AP turning on lower speeds, etc…
  • Reset AP back to factory defaults and setup open SSID (no security) for the DB to connect too.
  • Used different mobile phones (iOS and Android)
  • Turned off Firewall traffic inspection on router

I seem to be stuck in a loop between the DB and the APP. I go through the process of connecting up (white spinning lights), connect to the DB from phone, select the SSID for my wifi, watch the blue lights flash and the app bar go up. Seems to get to around 65 - 67% then defaults to left flashing white light. App eventually finishes and advises or error. Repeat process and go through the loop again.

I can see when the DB is trying to connect to the wifi that it gets an ip address from the router (sh ip dhcp bindings show an ip address for the DB MAC address). So it can’t be a wifi issue as it wouldn’t get an IP address unless it associates and then authenticates via WPA2. That is why I looked at the firewall on the router and turned that off, but still the same.

If I setup a hotspot on one of my mobiles, I can get the DB to register in the app. It has done a couple of firmware updates, but still getting the same issue when connecting via my home wifi. Have been through the app and used the change wifi option after the firmware updates, but still the same.

I tried to setup the Chime on the wifi and that connected first time, no issues with completing the setup and registering in the APP.

Anyone with any suggestions? I’m pulling out what little hair I have left with trying to get this to work. It really shouldn’t be this hard. Can’t find any documentation around TCP/UDP ports used in case I need to tweak the router config, but have turned Firewall off so shouldn’t be anything else to configure.

I set the wifi channel on my router to a specific channel eg 10. This solved my wifi problems

1 Like

I have the same exact problem, but only with my Doorbell 3 Plus cameras. I have about 8 doorbell cameras and 4 indoor cams. 6 of the doorbells went offline when the batteries died. The front doorbell and my original old doorbell is working because they are plugged in. The indoor cams are plugged in. But I’ve charged the batteries on the doorbells and even bought new batteries. The ones that aren’t working are all Doorbell 3 Plus. My Doorbell 2 was offline too but just now I added new batteries and it came back online seconds after the batteries were inserted. I hadn’t tried to reset it or anything. They should all turn back on with new batteries. I thought maybe something changed with my router but apparently not if my older doorbells aren’t having this issue. I’ve been dealing with this since August/September 2023.

Hi @Nerdgirl98. If the suggestions in this thread do not help, reach out to our support team to further investigate your concern. Give our support team a call at one of the numbers available here.