Ring Doorbell2 started showing power source as battery after 2 years.

I have a Ring 2 that is just over 2 years old. The other day I received an email saying I needed to recharge the battery. 1st time that has ever happened so I looked at the device health and it showed the power source was battery and not hardwired. It’s always shown hardwired. I pull the doorbell check all the connections and it’s getting power and everything is connected. Was there a firmware update recently or something that killed this. I don’t understand why it would do this after 2 years.

interesting, have you since charged your battery? if so, keep us updated on how it is performing. If this happens again, please let us know and we can certainly take a further look into the concern.

I have the exact same problem! I installed my Video Doorbell 2 two years ago this month. I connected it to my existing doorbell wires without the diode, per instructions, because I don’t have a digital doorbell. It has always shown the battery as charged and the doorbell as hardwired until a few weeks ago when it showed the battery was nearly dead and that the power source was the battery. The voltage from the doorbell transformer hasn’t changed. Sure could use an answer or a fix to this problem.

BTW, I haved recharged the battery and reinstalled about three times after the battery lost it’s charge and it’s made no difference. It’s currently recharging now.

Hey @Bookworm71 ! With it working for so long and seemingly nothing changing, I recommend checking the wires and connection areas for any corrosion or debris that might hinder a solid charge. Reconnecting was a great step to take! if you have not already attempted to, please also flip the wires to see if it helps secure a better voltage connection. If this does not lead to a hardwired trickle charge, it would be best to contact our support team at 800-656-1918, as it might need more isolated troubleshooting. Hope this helps!

Don’t bother with support, the only thing they will tell you is that you will need to buy a new Ring since it is out of warranty. At least that is what they told me.

Customer support was useless. I spent over 2 hours on the phone with them and they could not figure out the issue. Their solution, buy a new Ring 2. Of course it just happened to be out of the warranty period. They gave me a coupon to discount the new purchase however that doesn’t fix the issue. I replaced the transformer and nothing. We walked through resetting the ring, I checked the wires, I was getting power to the Ring and my doorbell would work, however nothing. I purchased a new Ring 2, connected it and immediately it showed it was hardwired and charging. Support was a joke. The person wanted to send me a new mounting plate. I asked him how does that have anything to do with my power issue. He couldn’t explain other than he wanted to send me a new plate. I told him on the original Ring I could see where the mounting plate comes into play since that is where you connected the wires to and the Ring slid onto that, however the Ring 2 you connect directly to the Ring 2 and it just screws onto the mounting bracket. Still no clue. If this happens again I am going to explore other options. I have invested a lot of money in Ring, with doorbell, cameras, alarm system, however it is not worth it if I keep having issues and support can’t/won’t help.

4 Likes

I trimmed the end off each wire, stripped them and re-attached them. My multimeter tells me there are 19 volts coming through the wires. After all this it’s still showing that the power source is the battery. Obviously there is something in the doorbell that becomes defective after a certain time frame since there is more than one post citing a doorbell that exhibits the same symptoms after a certain time period, apparently about 2 years.

I don’t know what is going on with this Doorbell 2 but now, this morning, it’s showing itself as “Hardwired” again and the “Status” is at 100%. Maybe it will stay this way for another 2 years. Who knows!

It’s back to “Battery” as the power source again. SMH

1 Like

Sorry to hear this concern is persisting @Bookworm71! The next best step will be to contact our support team at 800-656-1918 so they can troubleshoot more in depth. Please let us know how this goes.

Yesterday, 11/27, my doorbell did exactly the same thing. Mine is the original model doorbell and it’s been working with the transformer for at least two years. I received a message that my battery was at 4% and the unit was locked up. I had to do a hard reset before I could even get it reconnected after charging the battery. Reinstalled it and it’s still showing on battery. I took a voltmeter to the terminals and I still have 19V on them. So what happened?

This could be due to the surface your device is attached to if it is causing some sort of interference. Try letting your device hang from the wires to see if this continues. Feel free to gvie our support team a call at 800-656-1918 with any further questions or concerns!

Why does my ring 2 show power source as battery when it’s hardwired and the voltage is correct?

I had 19.4 volts AC at the terminals.
Reversing them made no sense to me so I just tightened them.
They had not been loose, but that fixed it.
Now hard wired, but no surround light.
Still bave only black and white video ? but will till winter comes.
None of Ring’s stuff survives outside in Winnipeg winters.

It does not look like Ring will fix or even try to address this issue

I will not recomment their products or buy their new doorbell 3 untill they get off their behind and give us good answers.

I suspect that they build in a timer so that you have to buy another piece of crap.

About a month ago my started working again. Didn’t do anything, just poof, like magic the power was showing hardwired.

I have had our Ring door bell for about 4 years and suddenly it stopped working. I couldn’t find our screwdriver to unscrew to investigate, so sent an email to RING about how to obtain another. Never heard back. Fortunately a neighbor who also has a Ring doorbell had the screwdriver, which I borrowed. Sure enough the power source stateside Battery which was depleted; although the Ring has always been hardwired and we have never had a problem in all this time. I rebooted, etc and got the power up to 100%. It still says battery as the power source, which is now down to 72% after 3 days. I don’t want to have to routinely charge something that I deliberately have hardwired, in order for it to work. We live in California, so no extreme weather. Any thoughts would be welcomed, especially from the RING STAFF.

Ring doorbell started showing power source as battery when it is hardwired

Same issue replaced transformer. Tested doorbell wires for voltage and amps. when touch wires door bell rings. Note the ring button will not ring door bell but does send alert to phone and ring extener. Shows on battery as powersource.

My Ring doorbell 2 has done the exact same thing. Worked great for about two years. I tested my voltage and it’s fine. I even removed and then reinstalled the doorbell. No luck. Seems to be an issue with my Ring doorbell. At one point the solar status indicated it was active. Not even sure what that is! I think Ring has a problem and needs to figure out why this happening and fix it.