Ring doorbell

I am running a ring app for mac version 2.5.1. I am unable to speak to a person at my door. The app does not appear under system preferences >privacy and security> privacy. Is this an app version that is not compatible with mac pro version Catalina 10.15.4?

Hi @Tyler208001. Since you are able to open the Ring app and do other things within the app, you don’t need to worry about any compatibility concerns! Back in your Mac’s settings, when you go to Security & Privacy, under the option for Microphone on the left hand side, do you see Ring under there (see attached screeshot for reference)? For the Ring app, just make sure this is checked. Then, when you are answering a Live View call from your Mac, just ensure you hit the green phone icon to “accept” the call and speak back to the person on the other side.

For a chance that you may not even see the Ring app under apps that could use your microphone, please let me know. If you could, please send me over screenshots of what apps have access to your microphones to showcase that the Ring app is not there.

No it does not show. As mentioned.

@Tyler208001 Thank you for that screenshot! Could you try removing the Ring app from your Mac, restart your Mac, and then reinstall the App and login? From there, do some testing to see if the person can hear you on the other side! In addition, if it’s still not working, could you check the Microphone settings to see if it shows up now, as well as if Ring shows up under your notification preferences as well?

I did and still nothing

@Tyler208001 Do you see the Ring app under notification preferences or accessibility? If you could, please attach some screenshots of what you do see please!

its not showing up in notifications and accessibility…

@Tyler208001 Just to confirm, after you recently re-downloaded the Ring app after removing it and restarting your Mac, did you trigger a Live View call? The Ring app will only request that permission for your microphone the first time that a call starts, so please ensure you’ve done this for me!

yes i have tried that

@Tyler208001 Thank you for confirming! I’m having my team that helps out with the Mac app look into this right now for us. Another question in the meantime: are you able to speak to someone on the other side through the Ring mobile app on your phone?


@Tyler208001 Thank you for confirming for me! I’ve been working on this concern with my team, who confirmed that if your app version you have downloaded is the most up to date (feel free to let me know which version you have), we may need to change some settings on your Mac! They shared this article with me and also this article if you could check both of them out and see if we can troubleshoot this with the Mac. Let me know how it goes!

I have contacted ring and they tested the same problem I am having on their computers and acknowledge the problem. There is no settings that can be changed. And this issue is with a Mac book pro. Not iPhone.

Same exact problem here. Works fine on the iphone but not on the MacOS and it’s not on my end. I use the mic regularly with other apps. It doesn’t show up in setting>sec and Privact>privacy

Tyler–This worked for me.


FWIW I had to shutdown after the terminal commands rather that simply restart in order to re-enable (“csrutil enable”). Other than that it was easy even if you aren’t comfortable in terminal. Just follow the directions exactly and cut and paste the commands. Whole thing took 5 minutes. Hope this helps. I was able to see the Ring app in Microphone access immediately.

Re: Ring doorbell

Re: Ring doorbell

Re: Ring doorbell