Ring doorbell wired and power adapter not working together, no power

I bought the ring wired doorbell and the power adapter. When I connect it up and plug it in nothing happens, the light ring around the button never comes on, tried pressing the orange button on the side, it looks like the doorbell simply isn’t getting power. I thought it might be the adapter but I can see using a phase tester that power is going through adapter wires to the contacts.

I bought through amazon uk but it was over 2 months ago so outside the return window(I was waiting 2 months for the power adapter to arrive). Should I try go through ring or amazon to arrange a warranty exchange?

Hi @k-dawg. I first suggest swapping the Plug-In Adapters terminals on the back of the Doorbell Wired and trying again. If the Doorbell is still not receiving power, you’ll need to contact our support team to sort this for you. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.