Ring Doorbell Wired and Chime cannot connect to any network

Hi, I have a doorbell wired and chime that got disconnected yesterday. Both were working fine since last November last year. I did not make any changes in my home network. Now both cannot connect to any internet (wifi, mobile hotspot). Here are the things that I tried, but could not get through. Please note that my wifi and mobile hotspot are both working fine and can browse normally.

  1. Reset the devices.
  2. Changed passwords of wifi and mobile data, even tried a no password to eliminate the special characters.
  3. Changed SSIDs to remove special characters.
  4. Tried changing the channels of my 2.4ghz several times, both lower and higher than channel 10
  5. Tried reconnecting to wifi option in the app and adding as new device
  6. Tried different mobile phones and tablets to add the devices again or reconnect to wifi
  7. Tried both the enabled and disabled location.

Signal strength is good. Power is OK from the last health update. I am literally a foot away from the ring devices when doing all of these.

I can see that the ring devices are connected to the APs or mobile phone through hotspot, but it keeps dropping the setup saying its not connected. These are for both the chime and doorbell.

I’m running out of options. Got this last year and had it shipped here to the Philippines. Any help from the ring support would be much appreciated. I don’t believe these devices got broken at the same time.


Hi @ChristianV. You are most likely running into these issues because you are using these devices in an unsupported region. You can find a list of regions that are supported here. Networks in different areas of the world may use different frequencies or channels, which can be problematic for devices not specifically designed for that region.

Just had the same problem today. All my 6 chimes (1st Gen and 2nd Gen) were working properly. Had an internet outage for a couple of hours but when the internet came back and all other ring devices (doorbell pro, floodlight cams, spotlight cams, stick up cam, Alarm base station, light bridge, etc) reconnected and got back online, only the chimes couldn’t reconnect back to the wifi. If I try to set them up, they couldn’t see any of the available networks.

Hi @Dax_Can. Try the following steps to address your concern:

  • Factory reset the Chimes by pressing and holding the set-up button on them for 20–25 seconds.

  • Reboot your router by unplugging it for a few seconds and plugging it back in.

  • Try completing your setup using a different phone or tablet.

If you have tried these steps and are still having the same concern, give our support team a call for further assistance.