Ring doorbell pro Won't enter setup

I have disconnected power. Let my doorbell sit without wires connected and randomly held buttons down and pressed repeatedly to reset capacitor. Let the doorbell sit disconnected or 10 minutes and pressed buttons.
Upon reconnecting power I get pulsating white light. After a few minutes it becomes a solid white light.
I press the doorbell and it rings both inside and outside but no matter how many times I press the stupid reset button it won’t go into setup mode.
If I hold it for 15-30 seconds it gets the pulsating white light and eventually goes solid white.
If I press reset again nothing. Also if I press doorbell it rings both inside and outside and the light goes dim but no matter how many times I press reset quickly or slowly it won’t enter setup mode.
I even removed it from the ring app.

Is it a video brick now?

P.s. I was hooking up my outside light camera and had to put it on a different wifi network and thats when I noticed the front doorbell had been offline since last night. I can put the spotlight camera into setup mode no problem.

Thanks. Frustrate.
JC

Hi @NEO_RULES. It sounds like you have done some extensive troubleshooting, thank you! One thing to note would be to make sure you have the Pro Power Kit installed and that your doorbell transformer has a voltage rating of 16 VAC, 30 VA. You can read more about Ring Pro power issues here. If those requirements are met, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

While I’m waiting on hold for Ring support for this exact same issue I thought I’d check the forums… it’s kind of shocking how many devices have exact same failure mode, and how obnoxious Ring is about acknowledging the problem.

Ring, please just issue a recall. Having us work through your poorly trained support representatives is painful for everyone involved and leading to a lot of bad will.

And please don’t blame COVID for an unreliable product and poor customer support.

Hi @nevetssf. I’ve answered this question in your individual post here.