Ring doorbell pro won’t enter setup mode

Hi I have a ring doorbell pro that won’t enter setup mode no matter how many times I try a hard setup or power off and on again. It was working okay for awhile but suddenly stopped working. Power supply is good it just won’t get to the spinning white light. Has anybody got any ideas on what to do next?

1 Like

Am having the same issue here too. Power is getting to the unit but it wont go in to Setup mode. It went offline about a week ago and haven’t been able to do anything with it since. Hopefully someone will have some ideas on here. At the moment I’ve just got a solid white light.

UPDATE

Further to me previous message I have been on the phone to Support and they have declared my unit dead. They are sending me a new one free of charge. I suggest you call Support.

1 Like

I have the same issue

I am based in Ireland and tried to setup the UK model without Pro Power Kit.

Tried to setup my Video Doorbell Pro yesterday.

First setup of the outdoor bell worked fine and I could test the video and audio coming through.

The existing chime had been already bypassed as per instructions provided, using the ring.com bypass cable provided in the box.

I then moved to install the chime - it took 5-7 minutes

After the chimes was setup I went to test the outdoor bell with the chime and I noticed that the device was blinking Blue at the top of the bell button and the app was saying that the device was offline.

I tried several times to re-connect it, following the instruactions on the App, but it constantly failed.

I went through your online help and follwoed the instructions to hard reset the device and re-setup from scratch.

Same results: as soon as I pressed the button on the right-hand side for entering in setup mode, the device started blinking blue and went in unresponsive mode.

From online literature, it appears the blue blinking light is a sign of not enough power reaching the device.

I read your support guide reagarding the use of the correct wire size (https://support.ring.com/hc/en-us/articles/360041807292-Selecting-the-Correct-Wire-Gauge-when-Wiring-a-Ring-Video-Doorbell-Pro) and the existing wiring seems to be of the right size (18-20 Gauge wire).

The remove the doubt that the problem was in the existing wires (they work fine with my existing doorbell - at 24V); I did another test, by using the ring.com additional wires provided in the box.

I connected one end (the wire part) of the ring.com additional wires directly to the ring.box transformer and the other end (the ring part) to the outdoor bell: same result.

I then did one final test, to eliminate the doubt that the issue was in the ring.com transformer provided in the box. I used a tester to check the power coming from the transformer and it measured around 19-20 V, which I understand it’s sufficient for the Doorbell Pro.

Please, I have now run out of options and I would like to get some answers from this thread.

Based on the tests conducted, I am afraid that the outdoor bell is faulty.

Should that be the case: unfortunately the device is out of warranty as it was bought long time ago and was left boxed for more than one year; however, as it was never used until yesterday, I would appreciate any goodwill gesture from ring.com (and Amazon - where it was bought it) for a replacement.

Thank you,

roberto

Thank you for covering all these steps @robydublin. If you are measuring enough power at the door and the Video Doorbell Pro is unresponsive, please ensure the bypass cable is securely installed and there is no loose wiring at the Doorbell terminals. Resetting the Doorbell, by holding the setup button for 20 seconds, might also help to get it into setup mode. Our support team is always available to assist with more in-depth troubleshooting as well. :slight_smile:

Happening to me too. Worked well for nine months though. Even if I insert a fully charged battery(and I bought an additional one just to be sure), there are no lights coming on at all. Trying to call Support but they work on European time and I am in Singapore. Help! It’s still under warranty.

Thanks for the response.
Perhaps my message has not been read in details or it has been misunderstood.
All suggestions you have provided have been already applied with no joy.

As said in my message, I have tested the outdoor bell by connecting it directly to transformer and not connected to the home wiring and the flashing blue light still persists.
I have also successfully resettled the device around 30 times, still no joy.
It is clear from the lack of alternative suggestions that the device is faulty.

If i am not eligible for a replacement I will consider alternative brands available in the market.
Thanks you
roberto

I am having the same problem since 05-07-2020. The device wont enter setup mode. I called ring customer support and the person on the other end said that these is something wrong with the device. It has been 1 yr and 5 months since i installed it so I am out of 1 yr warranty and they didnt give me a replacement.

It seems extremely odd that a bunch of us are experiencing the same issue start of May 2020.

A 300$ device lasted only 1yr 5 months. Not sure what to do now.

Was you device still in warranty?

Not anymore -

it was left boxed for almost one year …

Have not seen any further reply/support to my last calrifying post, hence I had to look for alternatives.

I have already contacted Smartzone who distribute SkyBell devices here in Ireland, which is one of the best alternative candidates together with Blink or ERA.

Pity that such a great idea may fail because of silly glitches and lack of support.

Please let me know you get an answer. I’m in the same boat.

1 Like

My R2 was not entering set up mode (looking to get it on my new WiFi network). I fully charged the battery overnight, and it worked after! I was surprised, but happy. My Ring is back to normal and up and running on my new network. Sometimes the simple fixes work!