Ring doorbell pro will not connect to wifi

I purchased my Ring doorbell pro in December 2019, along with the home security system. The doorbell worked great for a few months, but in March 2020, it lost wifi connectivity. The rest of my Ring security system has no issues connecting to my wifi. I have been in contact with Ring support several times. They’ve had me try everything from resetting my router, resetting power, taking pictures of the doorbell, chime and transformer (to verify power requirements), and even bypassing the doorbell chime. They eventually sent me another Ring doorbell pro, but the new one will not connect to my wifi either. I started researching wifi settings and issues with the Ring doorbell pro. I have set my 2.4 GHz channel (on my Linksys dual band router) to 1, as recommended in one post I saw. I’m running out of ideas and patience. Any suggestions?

I am currently having a similar problem. My wired Doorbell Pro has been working fine for the past 14-16 months, when all of a sudden last week it was not connecting. Mine was hooked up to a Chime Pro, and i believe that is what caused the malfunction because my Chime Pro does not seem to be working anymore (**doesn’t seem to be getting power when plugged in). My Doorbell Pro seems to be working because when i press the button, it still rings my internal doorbell, but it is still offline in the app and is not recording video. I haven’t had the chance to contact Ring yet, but plan to this weekend. Were you able to resolve your connectivity issue?

I’m having the same issue :frowning: instructions say push button on right side of panel but I don’t see any button

Not yet, but I did find this article. I’m going to try some of the suggestions listed in there.


I tried a few things in that article. I setup a guest network on the 2.4 GHz channel, but I was not prompted for a password when attempting to connect the doorbell to it, so that failed. I then tried doing the DHCP reservation to give the doorbell it’s own IP address. Article states to make the IP Address outside the range of the router’s DHCP, but the router did not allow me to do so. I gave it an IP Address within the range of my router’s DHCP and put the doorbell’s MAC ID in the DMZ, but none of this has worked.

I do have the exact same problem with my Ring Door Bell.

I tried everythin. Reset , disconnet and reconnect it. After a day it will go off line ( from the app ) . I rebooted my modem as well . Nothing seems to fix the problem.

I have the exact same issue.

Not good enough for a $400 doorbell!

And Ring seem to have taken away all support options aside from this forum (slow / painful) or phone (+ 30 minute wait times)

my doorbell pro will not connect to my wifi network.

Has anyone resolved this issue yet?

I’m with you…

The addresses given to the doorbell and ringer are I saw that both had the same IP address. Not too sure of how they’re going to connect to my subnet since I’m on a network. And they used for a DNS? How they get there I couldn’t guess, unless the doorbell has network translation protocol.

Nice idea they had here, poorly done unfortunately.

Same issue with mine. It lost wifi connection two days ago. It was purchased in November 2017, out of warranty. On the app, the ‘Last Reported Voltage’ states ‘Good’. Reconnecting it, my phone can’t detect the device Ring wifi signal. Talked to two support agents this morning and gave me instructions basically already outlined in the Ring app to no avail. The doorbell is still powered ON, thus makes a ring and triggers the mechanical ringer inside my house. I suspect there’s an issue with its wifi antenna.

1 Like

My ring devices showed up on my phone “setup” screen and I saw their address range was NOT in my subnet. So I set them for STATIC and put them into my subnet address range. This seemed to make them detectable. But the Ring setup said it couldn’t connect to the “Internet”. So I went back and reset the two devices (doorbell) & (ringer) to DHCP. Further attempts failed and I was just about ready to give up and I noticed that it probably wanted me to scan the QR code on the ring doorbell not the package. That did it! Setup proceeded pretty much as normal from that point.

However because I host websites I have a pretty secure firewall/router and ports must be opened manually… not like the consumer grade stuff most people own. So I had to set both WAN>LAN and LAN>WAN ports open. Then everything got happy. The devices found the Internet and disappeared from my “setup” on the phone. Ring didn’t do a very good job of install instruction for anything out of the ordinary.

I use Linux so used nmap -Pn to search for the IP addresses I set up. All 1000 scanned ports on 192.xxx.xxx.241 are filtered. So security seems tight enough…

Suggest you take a photo of the QR code on the back of the doorbell and back of the ring speaker plugin thing… and try again… If you can’t get it working see if those two items show up on your phone wifi setup screen… if so find out what your address range is and set them to static as mentioned above… you need to give them an address outside the DNCP range or it will always reset if power is lost…