Ring doorbell pro: Unable to remove faceplate screw

I have a ring doorbell pro. I recently changed my WiFi name and password, so need to reconnect the ring doorbell pro. However, I’m unable to unscrew the faceplate screw (windings might have got stripped). So, unable to access side button and enter setup mode.
My ring doorbell pro is pretty useless now without WiFi.
Please help.

Hey @venkatsubbu44. Some neighbors that find the screw is stripped and have a hard time getting it out have found relief by putting a rubber band in between the screw driver tip and the screw itself to get it to turn. Could you give this a try and let me know if it works for you too?

I am having the same issue with trying to remove the stripped screw on the bottome of my Ring Doorbell Pro that secures the faceplate. I tried using a rubber band, and also a latex glove, but neither worked. Any other suggestions beside snapping that faceplate off and probably breaking it?

Unfortunately, I couldn’t remove the faceplate at all. A professional might have removed it with better tools.

However, in my case I just had to reach the reset button on the side. So, I was able to pull the faceplate just enough (without breaking it) and hit the reset button.

Hey guys it is probably too late to help you guys but maybe some others are reading this for the first time. I just went through this because everything I read said it was a Phillips screw. Mine was not. I took it off with a set of curved needle nosed pliars.

The screw head I needed was a “T15” mine is a special screw and that’s why it feels stripped. Good luck!

1 Like