Ring Doorbell Pro stuck during setup

Hardwired Ring Pro. Has been working well. Changed the SSID of my wifi.
Trying to configure doorbell.

  • turned off ‘intelligent wifi’ on phone so it doesn’t switch away from doorbell wifi.
  • phone connects successfully to doorbell wifi, then app just sits there…for over 5 minutes with nothing happening…it never moves away from ‘connecting to your ring doorbell’ screen.
    I’ve done a reset on it and started completely from scratch, same result.
    Any ideas?
1 Like

Same problem here. White light is spinning. My phone connects to camera’s local wifi. But app just sits there on the “connecting to your ring doorbell” message.

Hi neighbors. If you are not able to complete the setup for your Doorbell using the Ring app on your phone, try the following steps:

  • Press and hold the setup button for 20-25 seconds to reboot your Doorbell.

  • Reboot your phone and disable Bluetooth.

  • Disable any active VPNs on your phone.

  • Try doing your setup on a different phone or tablet with the same account you used on the first phone you tried it on.

We also have this Help Center article with other steps to try when your setup is failing in the Ring app. If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.