Ring Doorbell Pro setup light doesn’t spin.

Ring Doorbell Pro will not go into setup mode. New installation, followed all of the directions, got to the point where it asks if the light ring is spinning, but it doesn’t happen. In fact, the ring is half lit, and then the final 3/4 of the ring just feebly blinks on and off. Tried uninstalling everything, reinstalling it again, same results. It’s connected to an existing mechanical doorbell, which functions fine. But connecting to the network ain’t happening. Run out of ideas. I tried uploading a short video to show what it’s doing, but Ring won’t let me upload a .mov file. So look at the two still photos and just click back and forth between them and you’ll get the gist of it.

are u sure the voltage of old door bel must be ac 5 to 24 volts from memoray

UPDATE.

So I went back out later that same day(7/4) and noticed that the doorbell light had changed from the twitchy 3/4 white ring, to a solid white ring. So on a whim I clicked the setup button again, and this time it all worked according to plan. The doorbell connected to my network, and everything functioned correctly…all was right with the world. Then 1am rolled around and it lost connection to the network, and all efforts since to reconnect it have been futile. It will go into setup mode, but then after repeated attempts to connect, and giving the error message “Unable To Connect To Network”, it gives up and says that I need to move my router closer to the doorbell; but that’s not really possible, as the router is literally on the other side of the wall from the doorbell…I can’t move it any closer. Additionally, this is my second Ring Doorbell Pro…and the first one is located on the other end of the house, and it has, thus far, had no problem connecting to the router. So I guess I’m back to square one, and I’m not sure what the next step is. The first doorbell installed flawlessly…this second one is being a PITA.

I honestly don’t know what the line voltage is. The exisiting doorbell is an OG mechanical bell & striker type, that was already there when I bought the house. But I can tell you that this is actually the second Ring Doorbell Pro that I’m installing…the first one connected to the same mechanical doorbell flawlessly and has worked great for over a year.

Still trying. Now the white ring is just slowly pulsing on and off, and the doorbell will not gonna into setup mode at all. It will ring the mechanical doorbell, but nothing else.
Asking these questions to myself is really cathartic, but the whole crowd source tech support isn’t very much help. If only I would have spent $200 for a doorbell and had actual tech support…oh wait.

1 Like

Hey @BrianEvens. Thank you for taking the time to detail and also update on what is happening in this chain of events for you. I’m sorry to hear that this is still to no avail, but it seems to be a power concern. I recommend checking out our Help Center Article here for more assistance on what to check to ensure power is good. If you continue to come up with no solution to get it up and running, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Let me know how this goes! :slight_smile:

My ring doorbell pro is doing the same thing. Any answers to this problem? I have a brand new one that I have just set up. Worked for half a day and now will not connect to the internet and it will not enter set-up mode. Tried absolutely everything.

1 Like

Ring’s ‘tech support’ sent me a blog post, that suggested that my doorbell wasn’t receiving sufficient power, and that’s why it wasn’t functioning properly. I already had one Ring doorbell that worked fine, but when I attempted to connect the second one, I got the results that you did. According to the post, the older transformer that powerred both original doorbells wasn’t powerful enough to power the two Ring doorbells. The second unit worked for the first day(just like yours), but then failed over night; turns out that’s ‘common’, because at night the doorbell fires up the IR lights for the night vision camera, and that is what draws the extra current and makes the unit fail…not enough juice. Coincidentally, I had this problem back in July, but theres been this dang pandemic going on, so literally YESTERDAY is when I was finally able to get an electrician to come into my house and upgrade the wiring and the transformer; they wired a new dedicated line to the transformer and then two new dedicated lines to both of my doorbells. I’m very happy to report that the first doorbell still works perfectly fine…but the second one, that started all of this in the first place… still doesn’t work. But now it’s 2 1/2 months later, I’m stuck with the useless $200 doorbell, and I’m $500 lighter on top of that. I would have been better off walking out into my front yard and setting seven $100 bills on fire.

So, good luck Clayton.

2 Likes

Exact Same problem for months … ive just finally had the patience to deal with it. Worked fine for a while and now I can’t get it to even spin the light… its a 200 dollar brick

Same EXACT issues. But I HAVE upgraded the transformer to the 24v reccomended by Ring, and sold along side their products at Home Depot. Ring is even sending a second Ring Pro for me to test against. This is a known issue that they ignore to address after several models.

1 Like

I had the exact same problem.

Ring eventually sent me a 2nd Ring Pro after hours with ‘tech support’ and me going full-Karen and insisting on speaking with a supervisor. The new unit arrived the other day, installed fine, even answered the door once, then bricked itself about 30 minutes later. It won’t enter setup now - just a solid white light after several minutes of a flashing white light.

Ring, you have a fault in your hardware you need to fix. Stop wasting our time with bad customer support and issue a recall. Or stop selling bad hardware. Or both.

I don’t normally post on forums but I’m on hold with Ring Support yet again so have time to kill.

1 Like

I just bought a refurbished doorbell pro, I bought a transformer with 18v at 1amp. (tryed with 127v and 220v to see if the amp would change something but nothing happened).

I left for 1 day on, and what I see was that the blue led was flashing on the top, but after 10 blinks I could hear like if he turns off, and the light up again, start blinking the top blue led…

After 6 hours i reseted and did the same thing doing a cycle.

I tryed to press the middle button and it rings, then after blinks the blue led, and goes to the withe led full circle but not blinking.

I tryed to configure the doobell, shows the wifi, and ask to change to the doorbell wifi, but I can’ find to conect then start blinking the top blue led again, and that’s it.

Could some one help me?