Ring Doorbell Pro not In Setup Mode and No Wifi

My Ring Doorbell Pro doesn’t work. It has power. When it is started I do have multiple issues. First, it didn’t get into setup mode, even after pressing the orange button on the side. Once that worked (after multiple ressets), it couldn’t find the Ring Wifi. Looking in the wifi setup of my phone Ring is not detected. With the setup of the Chime it worked well. I have reser the modem/router and also did do hard resets of the doorbell. Now the doorbell doesn’t come in setup mode anymore. I am lost and frustrated. How can this be resolved quickly?

I have the same issue with mine as well.
So frustrating!!

Hey neighbors! If your device is unable to go into setup mode, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.