Ring doorbell Pro keeps restarting and never goes to configuration

Hi, I’m having problems with my refurbish ring doorbell pro. In first I tried with a transformer that I had that was 16V, then I bought a 18v on Amazon that was saying that worked just fine:

then after changing I Still can’t go to the configuration mode… I left 2 days on, and the thing is that he start blinking the top blue, blink like 8 times, then stops, i can hear really close to him the sound like it was turning power off then the power on, then start blinking the top blue.

I think my doorbell pro its broken… because I already tryed to reset several times… and nothing happens…

if I click on the certer button it sound like I was ringging the bell, then blinks the white led all circle, and after 10 sec. turn off and then starts blinking the top blue again…

I tested with the voltimeter, and says 18v.

What I’m doing wrong or its a bad doorbell and need to be replaced?

Hi @Arrudard. For a reset, you’ll also want to make sure that you’re holding the setup button down for at least 20 seconds fully. Once the reset is done then you want to try setting the Doorbell back up in the Ring App. This is typically what I recommend for concerns like this, but it’s also worth noting that the power adapter you linked is not made by Ring so we cannot confirm it will work with the Doorbell Pro. You can find a compatible transformer on our website here and a power adapter listed here. These are both compatible with the Video Doorbell Pro, as having an incompatible power source could be causing the concerns you’re running into.