Ring Doorbell Pro fails after 1-ring!

I’ve had my Doorbell Pro since 2017, it’s wired and uses a Pro Power Kit installed inside the doorbell ringer. It’s worked pretty much flawlessly since then.

However, while it works now, I can open the app, got to live view and view outdoors, as soon as anyone rings the ring from outside, it rings the doorbell ringe and the chime and then fails. The only way to restart it is to remove the power from the Doorbell Pro, waits for it to connect and everything works again.

Nothing has changed. Same doorbell unit, same Ring Doorbell Pro, same chime, same Wifi Router with no change to config, nothing.

I can only assume that either the Doorbell Pro is starting to fail, or the Pro Power Kit is failing.

Anyone ideas, suggestions etc.?

Hi @4mc. I would first ensure that that all the connections in your Doorbell circuit are secure. This includes the back of your Ring Pro, Chime Kit and Doorbell Transformer. It’s also a good idea to take pictures of these while you’re there. If all these connections are tight, but this is still happening, I suggest reaching out to our support team. What you are describing is something we refer to as “dead on ding” and requires some diagnostics to determine exactly what is going on. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support. The support team might need to see the pictures I suggested earlier, so be sure to have them accessible.