Ring Doorbell Pro Continuously Goes Offline

Ring Doorbell Pro continuously goes offline after one button press.

I have a Ring Doorbell Pro and the power is connected to the Ring Plug-in Adapter.

Please help!

I know nothing about the doorbell pro nor the adapter - but - what happens if you disconnect the adapter from the db ? How about if you carry the doorbell into the same room as your router ?

The adapter is just power source so the power isn’t being drawn from the old school home doorbell.

It shouldn’t be a Wi-Fi issue because my router in in the living room which is the closest room to my front door where my Ring Doorbell is.

Fine. Happy Holidays !

Hi there, @47a16c3dcc13f6211ff8! It sounds like you are using a Ring Plug-In Adapter to power this Doorbell Pro? If so, power should certainly be sufficient. As you mentioned the router being close, please also ensure you are connecting to the 2.4Ghz wifi frequency, rather than the 5Ghz connection. I recommend also checking your Doorbell Pro settings in the Ring app, and ensuring the in home chime type selection is accurate. As you mentioned using a plug in adapter, there is likely not a chime kit in use, which means this in home chime type setting should reflect "none"or “no chime”.

If this did not resolve your concerns, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I’m having a similar problem. My Ring Pro requires that i pull the wires to reset the unit-power cycling the breaker is easy, but it resets everything tied to it.
After i reconnect the wires, I can go through setup-in 20 degree weather. Again. And Again. I have a Meshforce wifi system. Connectivity is very good to all my devices. Even the Ring Pro reports excellent connection, power, etc. But, after a few rings, it drops offline and I must pull the wires again and go through setup. My modem and wifi mesh system never loses power. Is this a Mesh system vs. Ring only problem? If so, is there firmware coming soon to fix it? If not, i need to dump this for a secure and reliable system.

I cannot even get my Ring Pro to connect at all. How did you get it to ever connect? I’ve been on with Ring and MeshForce. No one can figure it out. Do you have Ring Pro and what version of MeahForce do you have? We have M3S.

Hi @Brazup. Are you also using the Ring Plug-In Adapter? If not, what is the voltage rating for your transformer? We recommend a 16V 30VA transformer to properly power the Ring Pro doorbell circuit. You’ll also want to check and make sure that your Pro Power Kit is installed properly. Information about proper installation can be found here.

If you are still having this concern after checking out those suggestions, you can reach out to our support team for the next best steps. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.