Ring Doorbell Pro connection issue

Ring Pro doorbell is unable to connect video for several minutes once a visitor presses doorbell. It used to do just fine for past 1-year. But now we can only view recorded videos later (after 10 minutes view recorded video). But we have tried everything to resolve live view issues, we have installed the new Rapid Ring App, installed wifi mesh routers, get ring protect pro plan, etc. but are unable to resolve this issue. PLEASE HELP!! The security of our home is compromised!!

Any answers? Same problem and its frustrating!!!

I’m having the same issue. I was once consulted by a Ring Support specialist that this issue is caused by the ‘Mechanical Doorbell’ and my Ring Pro. I’ve turned off the doorbell chime in home, and my ring still doesnt re-initialize / connect to the wifi after someone rings my doorbell.

Please help.

Did anyone get a resolution to this issue? I have great wifi connectivity at the location, and has been in use for several years. RSSI is 46 and firmware has constantly been updated. Everything works except when someone rings the doorbell. The blue light freezes around the button and can not connect video until after recording is complete.

Hi neighbors! Checking the RSSI is a great first step. Ensuring that there is not too much distance or interference between your router and Doorbell will help with video quality. As the Doorbell Pro can connect to both 2.4 Ghz and 5 Ghz networks, I recommend choosing the 2.4 ghz network for best results. The next best step will be to remove and reinstall the Ring app on your mobile device, as well as ensuring there is not a vpn enabled.

If this concern persists despite checking the above, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I have had my Ring Video Doorbell Pro operational for over a year without any issues until a few weeks ago. It is hardwired and has RSSI of 46 or better consistently. If anyone rings my doorbell, I receive notification in mobile app, but get spinning wheel and live video is not possible until after the recording is completed. Any other time, I can get live feed very quickly and without any issue. Only when doorbell is pressed is there an issue. I suspected my transformer, so replaced it today with Ring unit. Same result. Have tried full factory reset of the video doorbell pro with same results. I have been on queue with support for over 2 hours and thought I would see if anyone in the community had ideas. Wifi is excellent mesh network, hardwired power, new transformer, firrmware is up to date and all other ring cameras working. Only the doorbell pro has issue when doorbell pressed.