Ring doorbell pro can't turn on

need some help. My wired ring doorbell had been working for about 3 years, now stopped working, basically it went offline and cannot turn on.

I checked transformer voltage and its output is more than 19V, then checked the voltage in internal chime which is about 0.6 to 0.8 (this is also where Pro Power Kit is connected), then I opened ring doorbell and the voltage it received is about 18.5V. So it’s my understanding that the transformer voltage is good, ring receive expected power. Do you see any issues with these findings?

I also tried 1) removed Pro Power Kit, retest, same thing. 2) I removed the 2 wires from ring doorbell and connect them shortly, my internal chime worked.

I can not connect ring doorbell directly to transformer because it’s quite far away and the wires are hidden in walls.

Could anyone has experience give me some clues or ideas what else I should try? Or is there a way to tell if ring doorbell itself is dead? or the Pro Power Kit is malfunctioning (I am not sure if ring doorbell can work without it)?

Appreciate any help!

I am having the exact same problem. I have checked everything. Did you get help?

I had the same problem around the 4-5 year mark, but it functioned intermittently during that time, having to be reset often. I recently learned from Ring associates, Reddit conversations, and IFIXIT site, that while you no longer have to worry with having a doorbell hardwired, you DO have to worry about an internal Li battery with a life span. During my troubleshooting, I discovered that there is a hidden micro-usb port that you can use to recharge the bell from my laptop. When I reconnected back to the home wiring, the video bell worked fine for some hours with the chime disabled via the app. Soon after I enabled the chime via the app and tested the chime (yes it rang), the video doorbell failed hard again, meaning I could not reset it while it was connected to the home wire. So, in my case, I think either the battery is dead, or something failed in the circuitry to recharge the battery if the path to recharge when hardwired is different than the recharge path via the micro-usb. Make sense? I’m not sure if it has been designed to last knowing now that there is a non-serviceable internal battery.

Hi neighbors. If you have verified you have sufficient power at the wires to power on your Pro but it is still unresponsive, try the following steps:

  • Reboot your Pro by pressing and holding the setup button for 20–25 seconds.

  • Power cycle your Pro by turning it off for a few minutes and then back on again.

If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.