Ring Doorbell Pro - can't connect to new wifi

Changed my wifi connection in my house and can’t get RING Doorbell Pro to connect. When I go in to reset network I can’t get the white circle to spin. I’ve tried to do a total reset by holding the button on the side of the doorbell for 30 seconds. Still won’t reset.

Hey @eagledrk. Thanks for letting us know that you’ve tried a reset already and how that’s worked. In this case, you may want to power cycle the Pro by disconnecting it from power for at least 1 minute and then reconnecting it. Go ahead and attempt to reset it by holding down the setup button for at least 20 seconds after completing the power cycle.

If the Pro is still not going into setup mode after trying those steps, please give our support team a call at one of the numbers availablehere. They can take a closer look and provide more advanced troubleshooting steps. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19here to see how to contact support. :slight_smile: