Ring Doorbell Pro - Cannot connect to Chime Pro or Network

Hi,

Two days ago my Video Doorbell Pro lost its connection and will not reconnect. It had been working fine for 7 months. It is hardwired.

The light is solid white and when I press the reset button to reconnect it, it remains solid white. I’ve tried holding it down longer but it always comes back as solid white.

I have two Doorbell Pros and a Chime Pro. They both connect to the Chime Pro Network. I’ve tried switching to my wifi network but again, I can’t get the doorbell into setup mode. I’ve also disconnected the power and let it sit for awhile. Same issue.

Anything else I can try?

Update on this.

I finally got the doorbell into setup mode. I’m not sure what I did differently but it gave me voice confirmation that it was now in setup mode and the white light spins. I still can’t connect to either my Chime Pro or Home Network though. It seems that the Ring network is never created so I can’t connect to it. I’ve tried on 3 different phones, all Android.

Hi there, @deans21! It sounds like the Doorbell Pro is trying to power up enough to perform a setup, but is doing so slowly. You audible indicator that the “device is in setup mode” should happen during setup each time, as should the spinning light to show setup mode is initiated.

Not seeing the Ring device broadcasted setup access point during setup could also be an indication of low power. Please power cycle the Doorbell Pro by powering it off for a few moments, then powering it back on. Next, allow the Doorbell Pro to power up for an hour or so to ensure it’s collected enough power for setup.

Once this step is complete, please reconnect your Ring device by following the steps in this help center article. Feel free to let us know how this goes! :slight_smile:

Hi,

Your steps are actually how I got to where I am now. I disconnected it and then reconnected and let it sit for a few hours. When I returned the light was spinning and I attempted setup.

I don’t think it is a low power issue though. It ran fine for 7 months and the power indicator has always read “Good”. I do get the audible “device is in setup mode” each time I try. The first time the setup failed though, I got a blinking white light on the left side which apparently indicates that a network was found but could not be connected to. Now when I try, it just tells me that it can’t find the device.

I’ve followed that article before. My wifi password hasn’t changed, device is on 2.4GHz band, I’ve disconnected and rewired the doorbell, rebooted the router and checked breakers. I’m not sure what is left to try besides resetting it again which I’ll do.

All of my other Ring devices are fine which includes another doorbell and security system.

1 Like

Thanks for the quick update on this! This is an interesting scenario indeed. Everything sounds optimal for setup to complete, and I agree that if your setup process is making it to the last step it is likely not power related.

In this case, and if possible, let’s try another mobile device just for this setup/ reconnection process. This will rule out any mobile device variables or Ring app factors. As you did before, I recommend attempting both Chime Pro and direct to router setup, although both should work as intended.

If this concern persists, the best next step will be to reach out to our support team for a more in-depth look. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to update us with any solutions you find.

Ok here’s an update…

I tried on two other phones but had the same issue. I still can’t see the ring network and it can’t connect to the Chime Pro. In fact, it’s back to not entering setup mode at all.

Since I have two of these, I decided to swap their locations in case it was something with the wiring. The doorbell from the side door was moved to the front and it works fine. The seemingly broken doorbell also does not work at the side door.

It seems the doorbell itself is having a problem.