Ring Doorbell Plus unreliable doorbell press notifications

I’ve recently upgraded from a Doorbell 4 to a Doorbell Plus

Since doing so, I’ve found notifications from doorbell button presses to be extremely unreliable.

People walk up to the door and press the button, and the door makes the normal button press sound, but none of my echo devices say someone is at the door, and no ‘Missed Ring’ or ‘Someone is at your door’ messages appear in the event history.

This is all caught on camera as a camera on the wall records this happening, and also triggers the doorbell to record as well.

Quite often, if you press the bottom again after a failed notification it will ring inside the home just fine, repeatedly. But after another period of not being used, will fail again on the first button press.

I don’t think WIFI is the issue as my Doorbell 4 never had any issues at all, and recorded video is crisp and sharp.

RSSI is normally in the low 50’s.

I’ve called Ring tech support once and it was extremely difficult to make them understand what the issue actually was, and then of course when they asked me to test it worked every time!

Has anyone else had a similar problem?

I’ve tried both rebooting the doorbell and doing a factory reset on it.

Hi @r5kod. You have tried all the basic troubleshooting steps I would have suggested for your concern. Here in the community, we can only offer basic troubleshooting steps, and if those do not work and more in-depth troubleshooting needs to be done, our support team is the one to help with that. The next best step for your concern would be to continue working with our support team to further investigate. You can also reach out to our support team on Facebook or Twitter by sending a private message to @Ring.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.