Ring doorbell not working after power cut

Hiya. So last week we had a power cut and the ring doorbell stayed offline for 2 hours after the power came back. Everything worked fine again for 36 hours and then the doorbell was back offline when we went on holiday. I got back to find that 6a circuit breaker (powering our two downstairs lights on too) had failed. I moved the cables to a spare 6a breaker and my lights have come back on but my doorbell remains dead.
I don’t seem to be getting power to the doorbell. Is it possible it needs hours to charge back up and work again or could the transformer have been fried by the power cut last week? I’m at a loss. Thank you.

Hi @Elpachio. I would suggest performing a reboot on the device by pressing and holding the setup button for 20 seconds, then releasing. If your doorbell does not show signs of life after that, you’ll need to contact our support team. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

HI Tom. I tried charging the battery manually and the red light would go off to suggest the battery is charged. I plug it back into the doorbell and nothing works. The setup button held down for 20 seconds does nothing, and even the “press” test button on the battery does nothing.
WOuld it be a dud battery after 4 years? Or more likely the transformer still? I can’t understand why it wouldn’t work if I manually charged the battery. Thanks

HI @Elpachio. It sounds like the issue may be with your Doorbell, as it’s not responding to any button pushes or charged battery. Feel free to reach out to our support team to get to the bottom of this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.