Ring doorbell not charging

According to wikipedia and other sources LiIon batteries can be permenatly damaged by charging below freezing. Ring’s own FAQ states that their Battery powered doorbells and Camera’s operate between -20 and +50 C, we’ve been around -10 to +10 C here the last week or so and I’m not seeing any charging or not enough to notice.

If I had to hazard a guess I would suggest that Ring adjusted the latest firmware to stop the batteries from charging below freezing in order to avoid damage. I know for a fact that this was not always the case as I have not had this issue in previous winters however it does make sense.

That said it would be nice if Ring gave people a heads up on this and/or made mention of it in their FAQ (assuming this is the cause). Most companies put out release notes when they update their firmware so that customers can see what was changed and know what to expect, where are Ring’s release notes for their firmware? I’ve looked and have not been able to find them. And if this is the case then why isn’t Ring support explaining this to people instead of just saying it’s too cold.

Of course the problem here is that if they admit that their products have reduced functionality anytime the weather drops below freezing (i.e. batteries won’t charge) they have basically eliminated themselves from the 50% of the U.S. and 100% of Canada which can see below freezing temps.

To be honest I have generally been happy with the Ring products, when they work they seem to be really good. However between this support (or lack thereof) and all the security issues in the past little bit I am advising people to reconsider and look at other options.


I’m having the same problem in SOUTH FLORIDA. No problem with freezing. I talked to customer service today and after multiple fixes, hardwired charging started again—-only to stop after a few minutes. Will try customer service again tomorrow

1 Like

So I contacted them by Facebook and their response was…wait for it…yup it is too cold. Apparently the trickle charge can only provide a maximum of 10% power per day and since I have lost 2.5% per day I must be losing 10-15% per day total with an average of 1 activation per day. Because that makes sense, or not. So then something is causing the device to use significantly more power then it ever use to or there’s a problem with it charging. Then they have the gall to tell me that my device is working as expected. I have found a number of posts stating that rolling back the firmware has fixed the issue so I am asking for instructions on how to do that and prevent it from updating again, maybe that will work. I mentioned to them that someone in South Florida was having the same issue so this idea that it’s the weather is just rediculos. There’s a problem here somewhere and either they don’t want to admit or are too stupid to figure it out.


I just went through an entire day trying to figure out why I was having the same issue. I have the correct transformer, wires all in place… it was not until I was about to give up that I replace the unit back onto the bracket and PUSHED really hard. I admit I was frustrated. It worked. Why? Because it was not making solid contact. The bracket was slightly twisted. When I pushed down to place it back on the bracket, it went on tighter than ever before. The white light came on. The app said “hardwired”. PTL it worked.


i called today. was told on there end (rings) my ring doorbells showed 100% on battery. I explained the app on both my android device & windows 10 pc show it as 91. since install it has gone down. i have everything shut off. been about 50F here. may i add new line ran. connected to a 24v 40Va. tested with my multi at the mount plate. recieving 30 volts. so its not my end. camera is band new a week old. happy i have the top plan. cause you guy will be replacing this at some point.

I’m having the same problem with my ring 2 device. The one on the front door works great the one I just installed on the back door is Not holding the charge.

1 Like

I am having the same issue. I have had my Ring doorbell for a few years and it is hard wired. I have never had a low battery until now.


I think the problem is the app itself. Mine’s hardwired and the battery has been going down and the app says the battery is at 83% so I just brought the video camera in to charge it but when I plug it in to charge it all of the blue segments are lit up inticating a full charge.

Update: after 5 minutes it’s now charging as if it’s at 83% so it seems that hardwiring my video doorbell is just for the light ring around the doorbell button.

RING!!, Please address this issue and not with a canned response. I apologize for sounding rude but this is a wide spread problem that isn’t being addressed and I’m very frustrated. The whole reason I went with Ring instead of the other guys is from what I had read before purchasing Ring was the way to go. Please prove me right!! The very least I hope I can get a replacement unit. By the way I live in Central Florida and it’s been warm.


I have been using ring door bell 2 for 3 years now, never had any single issue charging, 2-3 month ago, I started having the same thing and I have NOT changed anything in my install, since everything was working great! Something is wrong !!!


3 years and I had 0 issues, I live in canada and we get -40 degrees sometimes, the other days very very cold :slight_smile: welcome to canada, late 2019 something happened, we are not sheep! Also, something happened in front of my house and unfortunately, the battery was drained and I didn’t know, why, because everything worked great and I never had an issue! So I was surprised that my battery is at 0, same thing as you, how I have to charge every 2 weeks. Ring, FIX IT!

I live in Canada and for 3 consecutive years I had 0 issues, suddenly late 2019 I see power source battery, even though I’m hard wired, what you’re saying probably makes sense but that’s BS to me and ring should not do that, I lost 2 important happenings and I rely on ring for securely, that’s garbage ! I’m buying nest. That’s it for me. And like you, advising for people to stay away from ring. I own 3 Facebook groups with 100,000+ followers, I will make a difference.


Ring, you can’t have this many customers having the same issue that previously never had this problem, obvioulsly there is an issue on your end. Let us know you are working on an answer.


Their answer is , it’s cold … when other people having the same issue in Florida and Texas. So go figure. Check their Facebook page, it’s even worse.

When I talked to customer support last week, they had me basically reboot the whole thing and take the battery out, disconnect, etc. Once I was finished, IT WORKED–once! The second time again it went to no charging.

It seems that it fails to accept the electricity coming from the hardwire. I read somewhere that it installs the latest update available when it is activated by someone ringing or motion.

It is possible that when I “rebooted” it, it went back to factory original software and accepted power but once it was rung and installed again the latest software, it failed.

I am going to try customer service one more time and see if they can connect me to a technical person rather than someone reading a manual.

If someone else has any other ideas, let me know.

Yup, good luck with that, been there done that 2 times already and not only they read manuals and scrips , but they have no clue what they’re doing … this comes from a beta tester ! Ring is going down hard. Time to change

55f here today. Still not charging. Still at 91% hooked to a 24v 40va 30volt at terminals. Cold my but. It’s 55.should be charging.

1 Like

mdoyle845845 I hear you, doesn’t make sense at all! And as you see, they don’t even answer us.

Neighbors- I’m reading this post and it seems as if cold weather is the main culprit here. If you wish for more in depth troubleshooting, please call our support team at 800-656-1918. However, this sounds like expected behavior. Please review these articles for more information:

Also, if your device says battery instead of hardwired, make sure that everything is properly set up by following this help article.

Please also refer to our Community Guidelines and ensure that you are following them when posting. If you need help, please ask as we’d love to get your device up and running to its full potential. Please note, we will not tolerate negative behavior.

55 degrees isn’t extreme cold. And people in Texas report same issue. It’s not cold there either.

1 Like

Jennifer I am not buying this it’s been in the upper 40s the past 2 days, if this is considered extreme cold you have a serious problem. My unit is hard wired and only gets up to a max of 16% charged. I’ve never experienced this in the past 2 years.

1 Like