Ring Doorbell not charging properly


I am having an issue with my doorbell as it’s not charging properly.

The doorbell itself shows a solid blue circle however the app shows that the battery is draining - even though the actual unit is sitting next to me plugged into a wall charger.

I don’t understand it.

I know I can contact support but this unit is a replacement under warranty for a previous unit with an identical issue so before I start contacting support I wanted to see if you wise people could help.

It’s not hardwired in

I’ve tried different cables and different wall plugs - all of which do work with all the other devices in the house

I’ve tried logging out the app and back in (including even restarting my phone etc)

Signal strength is RSSI-47

I’ve run through the troubleshooting thing on the app - to no avail.

Can someone help?

I’m on the verge of giving up on Ring and getting a similar product on Amazon!

Charging usually take a few hours. If that does not work then try a hard reset by pressing the button on back for 20 seconds. Then all updates should download as it reconnects back to wifi network.