Ring Doorbell no longer displays LIVE view

I have a Ring Doorbell 3 Plus and have discovered that the doorbell goes into some form of power save mode which means it disconnects itself from the wireless. I can tell this because it is no longer a connected device on my sky router. If you try and connect for live view this fails because it’s not connected however when someone walks past or presses the button it wakes up and reconnects (it is then listed as a connected device) I have discovered when it detects motion or the doorbell is pressed the live view works for about a minute then stops again. I suspect Ring have done some code to help battery life but got it all wrong. I have an RSSI -50 and all the tests recommended by Ring pass fine. I suspect in a future firmware upgrade they will realise their mistake and fix it even if they don’t admit it.

I have had the same problem. It did work. But stopped. They gave me the same instructions.

Returning is not an option in that it’s too late. They won’t accept it. As that is the case, is everyone sticking with Ring or going to something else? I am disinclined to stick with a company that leaves your laundry in the wind and makes NO effort to help.

1 Like

Fixed it! My WiFi broadcast the same SSID and password for both 2.4 GHz and 5Ghz. So I changed the SSID of the 5Ghz and got my Doorbell 3 Plus to connect to this. I think it was trying to connect to both 2.4 and 5 at once. Now it can only connect to one bobs your uncle :slight_smile: Still not convinced it’s not the doorbell problem as I have no other devices that have a problem. Anyway it’s fixed for now at least.

2 Likes

My Ring doorbell 3 was on Wi-Fi 2.4 GHz have just switched to 5.0 GHz (different SSID). Tested and LIVE view worked. Fingers crossed it will continue to work. Thank you so much for the suggestion. Surprisingly my RSSI has fallen from 60 to 51.

I did not time pre above switch but now on 5 GHz to get Live view on Pixel 2 XL:

  1. Ring app about 12 seconds

  2. Rapid Ring app about 7 seconds

Rapid Ring app would be even better if individual widgets were added for doorbells.

I have the same problem. Seldom does this thing connect to live view. I have upgraded my router, switched to faster internet service, moved the router to within 6 feet, jumped up and down while rubbing my stomach and patting my head, and still nothing. Kind of defeats the purpose of having a remote door bell when I can’t even access the thing when I am home let alone away. Useless. I have other security cameras from Arlo and never have an issue connecting to them from anywhere. I wonder if they make an video doorbell cause this thing just plainly sucks!

5 Ghz does not work for me. In fact, I have set up an UAP-AC-Pro Access Point and have only my Doorbell 3 plus connected to it. I have tried 2 GHz only, 5 Ghz only, or both, but do not see any improvement. WiFi signal has always been great, but “Live View” just works intermittently.

The Chime Pro that I ordered will arrive soon, and I will see if it makes any difference.

I have just instslled the pro3 device and i a have full functionality except live view only works 10% of the time. I have not been able to get it to work when away from home at all. I have completed all of the fixes listed above. When i change from 2 to 5 ghz ans vice versa it eorks for approx 5 views and then reverst to same issue…

I have the same experience works for a day or two then reverts. This morning the RSSI had increased from 52 (yesterday) to 79 which made speaking to the delivery person almost impossible. Rebooted the node (Synology MR2200ac) doorbell was connected to and RSSI went back to 52. I will put this node on a smart plug and reboot every night to see if this helps.

Some updates: The retailer that I bought the original Ring Doorbell 3 Plus sent me a replacement and allowed me to keep the orignal one for a few more weeks for testing. With the two doorbells side-by-side connected to a dedicated Unifi Access Point, the replacement has been working well, with no issue so far (under various network configurations).

I also received the Chime Pro yesterday, and decided to connect both doorbells to the Chime Pro for testing. Interestingly, Live View is working well with both doorbells under this setup.

But I guess it might be too early to say something definitely right now, and I will continue to test them in the next few days.

Does anyone know if this issue has been fixed by Ring yet? There is still no live view available 6 months later. Live view works on LTE but not on home network, network config has not changed and the doorbell has worked fine for 4 years prior to May 2020. Everything points to a firmware update that has caused issues with IOS. Any commnent Ring ? When will this issue be fixed ?

I have the same issue. no live view. If I ring the doorbell, it give me live view for one time… then back to “Your phone is haviong trouble connecting to your ring doorbell”. This is extremely frustrating. especially considering its the christmas season and there will be a lot of deliveries! I have a ring Doorbell 2 pro. Full power. RSSI -50 did a full reset and it worked once… then nothing. Getting rid of it!

1 Like

My ring pro stopped displaying live view since a few days. All signals are perfet, rebooted everything,no live view on my MacAir and both Amazon displays. Live views work on my Iphone. Please fix this !

The amount of babysitting this product requires is absurd! ! I have run through the mountain of troubleshooting suggestions multiple times with only occasional but reliably temporary success, then back to square one. Not a chance of buying another Ring product - it shouldn’t be a part time job to keep it working - especially when the product is intended to enhance home security. If anyone has had better luck with a different brand, please share! Enough is enough.

1 Like

Does anyone from RING actually read these threads?
I can’t help but notice there are no answers or bug fixes in the pipeline being announced or responded to in this forum.
I posted these problems quite a long time ago, and have seen many, many more people suffering the same issues. I’m technically ‘savvy’ so am totoally convinced that there is noting more I can do here to improve the situation and that it lies firmly and squarely with Ring as a problem with either their software or infrastructure.
I have a £20 security camera built on the Raspberry Pi platform that, although not as high tech or slick looking, does 'very little less ’ than the Ring 3 doorbell ‘in it’s current condition’.
I had intended to purchase this as my first Ring device and potentially expand into additional cameras, indoor and out, and possibly an alarm system too; after this pantomime I’m wondering whether to bother recharging the Ring doorbell battery if /when it goes flat for the benefits it’s bringing me over a basic doorbell !!
Dissappointing Ring - such great potential - such poor exectution.

1 Like

Hey neighbors! This is a neighbor-to-neighbor support forum rather than a direct line to support, so if the suggestions mentioned in this thread do not resolve your concern, you’ll want to touch base with our support team for further assistance. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Many people on this thread claim to have called into tech support for this issue and the response from Ring has been useless. Most of us are tech savy enough to realize that if the device has power and a strong WIFI signal and coincidentally worked for 4 years seemlessly prior to this May that the issue is simply a firmware issue with Ring. I will try calling the support line again in the coming days and see what they say but I am guessing they have no fix for this issue since if they did it would have been rolled out in a firmware update within the last 6 months. The average user will not be able to open ports and mess around with the internal settings on a router so that really is an unacceptable response to this problem.

1 Like

As a last ditch effort I tried this fix and it worked. You have to go into your routers admin features and enable port forwarding as described in the articles below. Just tried this after struggling with this issue and the fix works, my live view now works when i am on the same WIFI network as my Ring doorbell. If you are not capable of modifying the advanced settings of your router you might as well return the Ring product as you will probably not be able to get it working otherwise.

Here is a good article explaining things.

https://www.adscon.com/sites/blog/Lists/Posts/Post.aspx?ID=52

https://support.ring.com/hc/en-us/articles/205385394-The-Protocols-and-Ports-Used-by-Ring-Devices

  1. Allow devices on the same Wireless Access Point (WAP) to access Live View. If you have an iPAD or Smartphone that is connected to the same WAP as the Ring Doorbell with the Ring App installed, you have to open some additional outbound ports on the firewall to access Live View. I created a rule from any device that has the Ring Doorbell App Outbound to the Internet on these ports:

  2. TCP 80

  3. TCP 443

  4. TCP 5228

  5. TCP 15064

  6. UDP 16500-65535

Following, same issue.

Ditto - "The average user will not be able to open ports and mess around with the internal settings on a router so that really is an unacceptable response to this problem."

And in response to the subsequent posters comments about having opened up ports and found this to work, please could you update after a few hours, as I did follow all the port opening options and found that it did indeed work for a ‘while’ (this is minutes to hours) after the updates to the firewall, but after this everything went back to being VERY intermittent.
I suspect that the perceived ‘solution’ was more down to the fact that the Ring Doorbell had been accessed repeatedly during the setup and testing of the firewall and had therefore not fallen back into what appears to be some sort of ‘sleep’ mode that seeminlgy only gets deactivated by either a number of motion activities in a short space of time, repeated requests for a Live View, or a ‘ping’ being sent to the device constantly to keep it alive.
If you send a ‘ping’ to a doorbell that has been idle for ‘some time’, you will get "destination unreachable’, if however you leave that ‘ping’ running and ask Alexa to “show me front door” (for example) then the ping will suddenly start to respond, even if, as is most often the case here, the Live View never actually appears.

1 Like

I have only read the last couple of posts on this thread so please excuse me if this comment is not relevant…

Does your router allow you to add the MAC address of your ring device into the DMZ ?

Just an idea (and not a long term solution).

1 Like