Ring Doorbell Live View on iPhone only works w/cellular, not wifi

When I use my iPhone and the Ring App to see the Live View, if I have wifi on, the Live View cannot connect. If i turn wifi off and just use cellular, then I get the Live View.

There was a similar post in Ring Community, but there it had to do with the wifi at work which was blocking video uploads. In my case, the wifi is in a home away from where my Ring device is, and the Live View gets blocked.

Any ideas on this???

Have you tried turning off the firewall of your router?

Did you ever find a solution? Mine is doing the exact same thing.

Also having the same problem - any solutions?

Figured it out - had to open a ports on my cable modem and now the live stream works - opened up TCP 15063-15064 - hope this helps others that might have this problem?

1 Like

Thx for the follow up. I will save your post in case this happens to me again. Mine started working again without me doing anything different! Maybe just turning off phone and restarting was enough to clear the previous block?? Don’t know.
Thanks again!!!

I have your exact same problem and drives me crazy. I have an Orbi router and I have tried everything to fix the issue. DMZ, port forwarding and so on. My signal to the cameras is excellent and if I cannect remotely I can get live view to work in less than a second. When I am connected from home it takes up to 30 seconds for live view to show something but some times it just doesn’t connect. I have noticed that my Echo Show 5 connects using the home wifi with no issues…not sure why it is the only device that properly works with live view over my wifi. I have tried ios and android apps almost with same results. What kind of router do you have?

I have this problem as well and it started maybe a week ago. I can’t see video with the Ring app or the Rapid Ring app while I’m on Wifi but if I turn WiFi off, they both work. I haven’t made any changes on my end, but I think the Ring app software updated recently because I now have the Mode Settings options.

I was on the phone with support for like 2 hours and here are some things we tried that haven’t worked:

  • Tried accessing the Ring/Rapid Ring app from my iPad and my computer.
  • Restarting my router (BGW210)
  • Opening ports on my router’s firewall: Ring SIP, 15063-15064, TCP/UDP, 15063, Ring RSS1, 998-999, TCP, 998, Ring RTP: 16500-65000, UDP, 16500, Ring RSS2: 6970-6970, TCP, 6970, Ring App1: 7076-7077, UDP, 7076, Ring App2: 9078-9079, UDP, 9078

I even tried another Ring Pro unit to see if there was a problem with mine, but it had the same issue. This is very frustrating, so if anyone has any advice on what to try, please let me know. Thanks!

I’m having a similiar issue where it would take at least 5-10 seconds to connect and that’s if it connects at all. I have an ORBI router as well. I tried tech support and after reviewing my setup, they claim it is “normal”?

I have 3 floodcam and they connect with the same hardware/wifi instantaneously and connects 100% of the time. Ring, please look into this as it makes the doorbell useless if I can’t connect to see who is there.

This worked for me, will never know why , but it worked. Thank you!

1 Like

Glad to hear it worked for you @Js121! For anyone who is still experiencing this concern, it looks like in most cases exploring the Ports and Protocol, as well as other network options, help to improve video connection. If altering network port, security, and streaming options did not resolve this concern, a great test will be to change the environment completely.

If possible, try connecting to video on an entirely different mobile device. This should eliminate factors such as conflicting 3rd party apps, mobile device features, mobile device network features, and other settings that might be interfering with the processing of video stream. Similar to the mobile device concept, if possible, please test video when connected to another network/ router. As most will not have a differently network to try, feel free to open up a standard guest network using a standard SSID, PW, and security type.

As some neighbors have shared success with the Rapid Ring app, see if this improves video connection times or quality. Feel free to let us know what you find! :slight_smile:

I am having the same issue. Everything had been working fine for a couple of years then today same issue as stated earlier. No video while contacted to home WiFi, cellular and VPN works.

No video on iPad or either of our iPhones
Video will work on cellular or VPN on iPhones and iPad
Tried the port forwarding, no success

I just find it strange that if I turn the VPN on it works, would that still be a router issue or ISP issue?

I have spent many hours searching the internet and trying every solution with no success.

We also cannot log on the app using WiFi, will work in cellular or VPN. Very frustrating.

Hi @aacreek. This is definitely an odd situation! I would think that this is a network related issue. You can try to test this buy connecting to a wifi hotspot and seeing if you get different results. Either way, I would contact our support team so they can help you deep dive on this and find out what the root cause is. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to come back with your results!

Thanks for the response.

I did try over a hotspot and it worked fine, just like when it worked on cellular.

I finally resolved the issue by resetting my IP address through my PC. I thought that by resetting my router and modem would have done the same, but I guess not.

1 Like