ring doorbell is frustating me - video doesn't load and only sound is static

Just bought our first ring doorbell (ring doorbell 3) and was eager to get it setup - went through all the steps to set it up and get it placed in the spot I wanted.

Issue is if someone rings the doorbell - the video doesn’t load up all the time or takes and absolute age to load. And if it does it freezes and it is not allow us or the person at the door to speak - we only hear static.

Did I receive a faulty machine or is there a fix for this? I am getting very annoyed about the whole experience.

Hey there, @eowallace! Audio/ Video connection concerns are often related to wifi, mobile device, or Ring app communication variables. The best first thing to check is your wifi signal strength, or RSSI, which can be found in the Device Health section of your Ring app. Check out our Community post about RSSI for tips on optimizing this signal strength.

Removing and reinstalling the Ring app is a quick way to ensure it is up to date and optimally integrated with your mobile device. On your mobile device, try testing video on wifi only, and then on data only, to see if either connection is more efficient. Please also ensure bluetooth and VPN is disabled. I hope this helps! :slight_smile:

1 Like

Thank you for reply Marley,

Unfortunately I am still having the same issues -

The video continues to freeze and the static noise is just not going away.

I went through all the steps you listed below and checked everything out -

My RSSI is -54 (which from your link is sufficient - I know not the best but it should be working correctly for me).

The wifi strength is marked as good in the Device Health Report / I have even moved my rooter from its normal position so that it is closer to the doorbell as well.

I have deleted the app 2 / 3 times now and reinstalled it.

I have reset up the doorbell to factory settings at least twice and still the same problems are still arising.

I have tried it with Wifi or without as suggested and it is stll the same issues. Also gone with bluetooth off to see if that helped and no it didn’t.

I am continuing to get videos that have freeze in the middle of them and time continues and the static noise is not disappating. It is getting very frustrating as I was hoping to have this setup to be clean and easy as possible but that is not the case.

Can you pleaes let me know what I should do now - do I go back to the shop and ask for a replacement one / or is there a fix that can be done remotely.

Looking forward to hearing from you.

Eoin

I am having a nearly identical experience. All of my friends raved about their Rings, so we picked up one on Prime Day. Since then we have had nothing but frustrations with it.

  • Too many false positives, despite tweaking the sensitivity many many times.
  • Less than 25% chance a live connection works.
  • Poor connection quality on the rare occation that it does connect
  • Capture images have never once included a person, after more than a month of frequent package deliveries

Honestly, I’m getting pretty fed up. I have tried all the troubleshooting options, even going so far as moving the router to just on the other side of the door, and still the same issues. I’m starting to think that I got a lemon.
Since I was considering an upgrade anyway, I’m going to try a new router and see if that works. If not, I’m switching back to my Nest. While it lacked a lot of the features of the Ring, at least it worked.

Sorry to hear this concern is persisting, neighbors. You’ve certainly covered majority of the steps that i’d recommend here. Testing Ring app operation on another mobile device, if possible, can rule out many mobile and app communication variables.

If you have another router to test, or even a free mobile hotspot available, this is a great way to temporarily test a new connection and see if the results are improved. Depending on the model of router being used, there may be some network settings that can improve streaming or connection.

Outside of testing these main factors for audio/ video, the best next step here will be to reach out to our support team for more in-depth troubleshooting. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

1 Like

I am all sorted now, thank god - one thing that I did different was reboot my router as well, and I did get onto your support team as well.

Thank you for your help -

1 Like