Ring doorbell has power but camera and unit says offline

I have tried resetting the unit powering on and off and still won’t connect to wifi. Need to replace?

Same thing for ours. We have two floodlights and both worked great and connected to our wifi perfectly until the Ring Sidewalk opt out date. (June 8th) Now, one floodlight works fine and the other will not connect for more than a few minutes. We have power cycled, reset the device, tested our wifi strength and even have two chimes that are supposed to even increase the wifi signal strength. Nothing has changed with our devices, wifi, etc and are at a complete loss. I wish Ring would help shed some light on this. Several others have had the same issue and posted on here. Sounds like it’s a Ring issue.

I’m having the same issue. Ring doorbell has power but won’t connect to my wifi even though it was connected before. The ring doorbell just keeps telling me password must have been entered incorrectly ( it is not). How do I get it back online? This is really frustrating.

Hi there, neighbors! When reconnecting your Ring device, please follow the steps in this help center article. Try also opening a standard 2.4 Ghz guest network on your router to rule out any special settings, or network changes. @vicki87, as you mentioned password concerns, try updating the password to not contain too many special characters, spaces, or too many characters in general, as a test.

With these devices having worked prior, and if you have not already, please unplug your router and plug it back in to reset the network. This can help clear up any network errors.

If this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know how this goes. :slight_smile: