Ring Doorbell gen2 lost WiFi - hard reset fixed it

My Ring doorbell Gen 2 went offline and would not reconnect to my WiFi. Doorbell chime outside and inside mechanical chime still worked when pressed. I went through the WiFi reconnect process, always getting the “Rome wasn’t built in a day bs “ and then it would fail saying my WiFi password was incorrect. WiFi SSID signal was strong and all other Smart TVs and mobile devices were all working fine on the WiFi network. The password was correctly entered every time.

The fix was to hold the square black reset button in the indentation at the top backside for about 15 seconds. The device reset and WiFi setup was successful… this seems like a firmware bug that many people are hitting. It better get fixed soon as I can not rely on the unstable product much longer

This did not work for me anymore ideas?

Hi @az101st. Try posting the specific problem that you are having, as this will help neighbors in the Community to be able to identify the issue and help you implement a fix. :slightly_smiling_face: