Ring doorbell elite POE will not join network after modem swap?

Ring Video Doorbell Elite, unable to connect to network after modem swap.

I have a Ring video doorbell elite that is POE unit . We have had this unit in use for a few years, same address, same ISP without issue but week or so ago I had some issues with our Spectrum internet connection which resulted in a technician coming out and replacing our modem. We also have a TP-Link Deco x60 mesh network router and after the modem swap only about half of the devices reconnected without issue. The others I had to delete from the known list before they would reconnect… but my ring doorbell has not been able to reconnect, I have put it in setup mode. I have held the reset button down for 10 seconds until the light flashes blue so that it resets the network connections it responds and states it’s going to connect to the network. But states it was unable to connect to the network every time. I removed the unit from the front of the house and plugged it directly to the modem with a new ethernet cable to eliminate it was the long ethernet cable ran from the power adapter to the doorbell unit but got the same result. Anyone know what might have caused this? I don’t believe I had any static IP addresses saved on the old modem or anything that could have changed If I remember correctly any help would be greatly appreciated.

Hi @user41878. Those were good troubleshooting steps to take to try and resolve your concern. When you reset the device, you should hold down the setup button for 20–25 seconds. Try doing the reset once more and then reconnecting it to your wifi. I also suggest rebooting your router by unplugging it for a few seconds and plugging it back in. Verify that you do not have a VPN installed on your network as well. If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.