Ring Doorbell Elite Does not enter set-up mode

The builder just replaced ring with one that is blinking white ring. its hardwired through eternet. I tried to reset by pressing at top corner for 15 seconds, it always says unable to join the WIFI Ring Setup ## network, tried to connect through wifi same message appear

Hey @Tamatem. Are you able to try the setup from another device? If the device will not connect to the setup network from another device with the Ring app still, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Let me know how this goes! :slight_smile:

I’m having this problem as well. I thought it might have been my router, but I have since replaced it with a much better device and I am having the same result.