Ring doorbell connects to "incorrect" TP-Link Deco M4 mesh unit

I noticed my newly installed doorbell showing a weak wifi signal (RSSI 73) which surprised me seeing as there is a Deco M4 unit close by. I can’t speak to delivery guys because speech (both ways) is very broken.

When I check my Deco mesh system for connected devices I can see that the doorbell has connected to my “Main Deco” in the living room which is quite far away and would offer my front door a weak signal.

How do I get my doorbell to connect to a different mesh unit?

All my other devices (phones, laptops etc) connect to the strongest signal (mesh unit). Only Ring seems incapable of doing that.

Hi @Ivys! When using any mesh network, the control of devices connecting to nodes is best done via the network settings. I’ve seen other neighbors share success in unplugging certain access points, and leaving the desired one powered for connection. The Video Doorbell should then connect to that access point, and you can then power up the other nodes.

To avoid the Doorbell switching connection, it’s best to ensure there is not another access point close by. I recommend also checking for any dedicating, prioritization, or roaming settings in your network options, to see if this helps. :slight_smile:

1 Like