Ring doorbell cannot connect to internet

I just tried to set up my doorbell and it fails to connect to the internet. My internet is good and I just cannot get the connection. Without this the doorbell is useless.


Hey there, @xdmarie4near! Can you let us know what is happening when you try to set up the doorbell? Does it say that the Wi-Fi password is incorrect, or that it couldn’t connect due to a poor signal? I recommend attempting to set up the doorbell while right next to your router, then once it is connected, move it to the desired location. If possible, can you attach a screenshot of your error message you get when trying to connect it? Hope to hear from you soon!

I get the same thing, once the Ring 2 finally times out, it flashes left (not able to connect to xFinity wi-fi). I’ve disabled VPN and cancelled all background updates on the iPhone. Sometimes Ring will actually show up in the Devices menu on wi-fi, but it never “fully” joins.

1 Like

I’m configuring the device right next the router, which I’ve rebooted several times. The Ring joins the Ring network and will (often) attempt to join my 2.4 wi-fi, but never manages to complete the join to my w-fi. Any suggestions?

1 Like

Hey @Jim2! Can you provide a screenshot of the error message you have when it says it cannot connect to your Wi-Fi network? Also, take a look at this help article! You may need to call your ISP and check on your ports and protocols to make sure that they are ready for a Ring device to be added to your router’s network.

I read further and because it is at the opposite end of my house from my router I needed to order a Ring Chime Pro. I wish I had known this before buying the Ring2.

I too am having connection issues with the Ring Video Doorbell. Going through the setup fine til it attempts to establish internet connection via my wifi network. I can see the device in the connected devices briefly. I have internet service provided by Xfinity Comcast. My router/gateway provides two networks. a 2.4GHz and a 5GHz. The doorbell needs to connect via the 2.4GHz network. I followed one try which was to disable the 5GHz network. That did not correct my issue. Our speeds are excellent. I have rebooted the router multiple times. I have performed hard resets on the device multiple times. I have multiple devices that use the wifi, they are all performing excellently. In fact, I just connected a new Amazon Echol Show to the network without any issues. Any advice. Ring support suggests the device is faulty and should be returned. But I’ve read several topics in forums that said that didn’t fix their problems. Just wanted to exhaust all possible “fixes” before returning to the store.


What kind of phone are you using? You could try with another if you have one. I know some Android phones have wifi options that will switch you to data is internet can’t be found on wifi. If you have one, you need to turn this off first. When the phone connects to the Ring device it will not be able to get an Internet connection and switch to data. This will cause the connection to fail. Hope this helps.

I am using an iPhone 8+, and I also attempted with an iPad Air. No success with either the phone or the iPad. I turned off celluar data also and set the phone to the 2.4GHz network. Still a fail…

1 Like

The only other things I can think of is if you are using a VPN or any ad blocking service with you devices or router. I’ve seen others report that this caused problems as well. I’m sure Ring support already had you uninstall and reinstall the app.

Thanks Eagle328…

I am not using a VPN on this device/router. Nor, do I have any ad blocking software running. I was not instructed to uninstall the app and reinstall. I’ll try that…



That didn’t work either.

Attached is a screenshot of my setup failure.

Left Flashing White is what the Ring Doorbell is doing.


I spent most of today researching this problem trying to connect my new doorbell. I chatted with a Frontier rep about how to build a routing table for a custom application for Ring. The rep told me it was out of their scope to do that. Interesting, but the wrong answer. First, let me say that my router is 2007 vintage. It says Verizon on it and is a model M1424WR. In its list of custom applications, none used the same ports as Ring, so I knew I needed a custom table. I edited the router config and behold, my Ring Doorbell works. If you have a Ring that does not connect to the internet, I would first suspect your router configuration.

You can find the custom table ( The Protocols and Ports Used by Ring Devices) you will need at:


1 Like

My Ring Doorbell is not connecting to the WiFi

1 Like



The issue you have been offering help and tips on is still on going for me. However, I now know what the issue is. The Xfinity Comcast Gateway security for IPv4 was set at maximum security. Under this setting the doorbell will not connect to the internet. I lowered the security level one position form max. to typical and the doorbell now functions properly. Xfinity Comcast Tech Support Team is working on the port/protocol set up I need in order to take my security back to Maximum. They tried to send a refresh signal with new protocols. However, that didn’t resolve the issue. They have advanced the ticket upstream and I expect an answer within 24 hours. Thanks for your assistance.


Glad to hear it’s working and you know why it wasn’t. There are so many things like this that make troubleshooting so complicated. My provider Verizon, had no issues. But everyone is different.

What do I try next?

My ring doorbell wont connect to the internet. The light on the front doesn’t even flash it just stays solid. I’ve tried resetting it and it just wont flash.

Im having the same problem… Did you get a resolution for the connection to xfinity??

No I did not! Xfinity Comcast was no help! I changed my firewall security to one level below maximum and the doorbell is working correctly