Ring doorbell battery fully charged shows low on app

Tried two fully charged batteries in ring doorbell but showing 18% battery level in app. Used live option, uninstalled and reinstalled the app. Still showing the same percentage on app.
What can i do to fix this?

Try waiting overnight before you check the battery %.

No still not showing full battery level

Hi @ad5eb24c4a0b944cff295d00e44e6c. The best way to cause your Doorbell to reflect the most current information is to press the doorbell button to prompt a ring event. Once the event is over, give it a few minutes and all the information should be current. Let me know if this helps.

Tom, I am having the same issue. I both waited overnight and then pressed the bell to reset. Neither has worked. Battery shows critical low 2% yet was fully charged last night.
It also is connected to a power source.

1 Like

Hi @user18791. I suggest performing a reset on your Doorbell. You can do this by pressing and holding the setup button for 20 seconds, then release. After you do this and reconnect to WiFi, check the RSSI of your Doorbell. If you have a low RSSI, this could be the issue you are facing. I hope this information is helpful.