Ring Doorbell 3 wifi problems

I just got my ring 3 today and have spent the last 3 hours trying to get it setup. When I try to connect to my wifi on the normal SSID it flashes the right lights and won’t connect. I have tried a hard reset and no change. I have tried two different devices (iPhone and Ipad) with no luck. However, If I change to my guest network that runs off the same router, same password encryption type, and same settings all around it connects. I just prefer to have it on my main network so there aren’t any linking issues with other devices. Any help would be appreciated.

UPDATE:
Ring forced a firmaware update to the device and forced a reset to the wifi. You might want to call them or setup the device again in order to correct the problem. Good luck.

[ORIGINAL RESPONSE]

Having the exact same issue. Have swapped out my batteries 4 times now thinking it was my system that was a problem. Apparently, it’s RING. Unfortunate they don’t have a staff to notify customer when their service is down or having an issue in order to help mitigate the problem.

This is also my second message in trying to respond as their system continued to throw back ‘error’ messages from their server when I attempted to post.

Let’s see how long this takes to correct…