Ring doorbell 2nd gen

So, this is the 2nd Ring doorbell now with the same fault. I’m at a loss really. It’s been fine, had it 2 weeks now. Suddenly, no live view, it can’t activate the camera. Health check is fine with a green reading of -58, which it has been all the time. It’s hardwired and showing it is with good battery % showing. It worked until today. My internet is fine. Nothing has altered. It makes no sense. It’s so frustrating. I don’t think it’s my phone, tried a different device, same thing. I could reset it, but am I going to have to keep doing it.

Any help please, gratefully received.

It’s the 2nd gen one.

Maybe I need a different one. There’s a new one coming out in May.

Hi @ffiscool. There are a few factors that can contribute to issues with Live View. This Community post here has some great tips and tricks for Live View. Try these suggestion as well as rebooting your internet router to see if that improves your Live View experience. The Rapid Ring app also works great for Live View. I hope this helps!

Same here nothing works its became unusable… very sorry for having payed a great deal of money on this